U.S. Department of Energy
Office of Repository Development

User Information Document for: WINGRIDDER Version 3.0

REV. NO.: 00

Document ID: 10024-UID-3.0-00

STN: 10024-3.0-00

Prepared by:

Lehua Pan
Lawrence Berkeley National Laboratory

Signature

Date: 6/12/07
DISCLAIMER

This report was prepared as an account of work sponsored by an agency of the United States Government. Neither the United States Government nor any agency thereof, nor any of their employees, nor any of their contractors, subcontractors or their employees, make any warranty, express or implied, or assumes any legal liability or responsibility for the accuracy, completeness, or any third party’s use or the results of such use of any information, apparatus, product or process disclosed, or represents that its use would not infringe privately owned rights. Reference herein to any specific commercial product, process, or service by trade name, trademark, manufacturer, or otherwise, does not necessarily constitute or imply its endorsement, recommendation, or favoring by the United States Government or any agency thereof or its contractors or subcontractors. The view and opinions of authors expressed herein do not necessarily state or reflect those of the United States Government or any agency thereof.
<table>
<thead>
<tr>
<th>Revision</th>
<th>Date</th>
<th>Purpose of the Revision</th>
</tr>
</thead>
<tbody>
<tr>
<td>00</td>
<td>6/12/2007</td>
<td>Initial release</td>
</tr>
<tr>
<td>CONTENTS</td>
<td>Page</td>
<td></td>
</tr>
<tr>
<td>----------</td>
<td>------</td>
<td></td>
</tr>
<tr>
<td>1. INTRODUCTION</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>1.1 PURPOSE</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>1.2 SOFTWARE IDENTIFICATION</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>1.3 DEFINITIONS</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>1.4 TRACEABILITY</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>2. USER INFORMATION</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>2.1 INTRODUCTION</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>2.2 HOW TO USE THIS SOFTWARE</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>2.2.1 2D Grid (column scheme) Development</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>2.2.2 3D Grid Development</td>
<td>3</td>
<td></td>
</tr>
<tr>
<td>2.2.3 Development of a hybrid grid</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>2.3 INTERACTIONS WITH THE SOFTWARE</td>
<td>5</td>
<td></td>
</tr>
<tr>
<td>2.3.1 Management of Projects</td>
<td>5</td>
<td></td>
</tr>
<tr>
<td>2.3.1.1 Creating a new directory/Getting in an existing directory</td>
<td>5</td>
<td></td>
</tr>
<tr>
<td>2.3.1.2 Opening an existing project</td>
<td>6</td>
<td></td>
</tr>
<tr>
<td>2.3.1.3 Saving a project</td>
<td>6</td>
<td></td>
</tr>
<tr>
<td>2.3.1.4 Closing a project</td>
<td>8</td>
<td></td>
</tr>
<tr>
<td>2.3.2 Loading Input Files</td>
<td>8</td>
<td></td>
</tr>
<tr>
<td>2.3.2.1 Domain boundary and subboundaries</td>
<td>8</td>
<td></td>
</tr>
<tr>
<td>2.3.2.2 Repository</td>
<td>9</td>
<td></td>
</tr>
<tr>
<td>2.3.2.3 Faults</td>
<td>9</td>
<td></td>
</tr>
<tr>
<td>2.3.2.4 GeoLayers</td>
<td>9</td>
<td></td>
</tr>
<tr>
<td>2.3.2.5 Drifts</td>
<td>10</td>
<td></td>
</tr>
<tr>
<td>2.3.2.6 Boreholes</td>
<td>10</td>
<td></td>
</tr>
<tr>
<td>2.3.3 Column Design and 2-D Grid Generation (map view)</td>
<td>10</td>
<td></td>
</tr>
<tr>
<td>2.3.3.1 Getting in Design mode</td>
<td>10</td>
<td></td>
</tr>
<tr>
<td>2.3.3.2 Assigning nodes for objects</td>
<td>11</td>
<td></td>
</tr>
<tr>
<td>2.3.3.3 Interactively adding node</td>
<td>12</td>
<td></td>
</tr>
<tr>
<td>2.3.3.4 Selecting a node</td>
<td>13</td>
<td></td>
</tr>
<tr>
<td>2.3.3.5 Cleaning nodes</td>
<td>13</td>
<td></td>
</tr>
<tr>
<td>2.3.3.6 Moving nodes to new locations</td>
<td>13</td>
<td></td>
</tr>
<tr>
<td>2.3.3.7 Viewing a node’s Name, LBNL name, and KIND</td>
<td>14</td>
<td></td>
</tr>
<tr>
<td>2.3.3.8 Modifying the KIND of a node</td>
<td>14</td>
<td></td>
</tr>
<tr>
<td>2.3.3.9 Saving node information to a disk file</td>
<td>14</td>
<td></td>
</tr>
<tr>
<td>2.3.3.10 Generating a 2-D grid</td>
<td>15</td>
<td></td>
</tr>
<tr>
<td>2.3.3.11 Loading a 2-D grid into memory</td>
<td>15</td>
<td></td>
</tr>
<tr>
<td>2.3.3.12 Select a connection or a segment</td>
<td>16</td>
<td></td>
</tr>
<tr>
<td>2.3.3.13 Interactively delete unwanted segments</td>
<td>16</td>
<td></td>
</tr>
<tr>
<td>2.3.3.14 Interactively moving a segment</td>
<td>16</td>
<td></td>
</tr>
<tr>
<td>2.3.3.15 Adding other objects (lines, circles, and polygons)</td>
<td>17</td>
<td></td>
</tr>
<tr>
<td>2.3.3.16 Deleting unqualified segments</td>
<td>18</td>
<td></td>
</tr>
<tr>
<td>2.3.4 Preparation and modification before 3-D gridding</td>
<td>18</td>
<td></td>
</tr>
<tr>
<td>2.3.4.1 Design vertical layer structure</td>
<td>18</td>
<td></td>
</tr>
</tbody>
</table>
2.3.4.2 Correcting singular side column ................................................................. 19
2.3.4.3 Update repository columns .......................................................................... 19
2.3.4.4 Remove word from column property .......................................................... 20
2.3.4.5 Add word to column property .................................................................... 20
2.3.4.6 Assign ‘KIND’ property based on regions .................................................... 20
2.3.5 Generating 3-D Grid ...................................................................................... 20
  2.3.5.1 Building cells and vertical connections only ................................................. 20
  2.3.5.2 Building lateral connections only ............................................................... 21
  2.3.5.3 Building the full 3-D mesh ........................................................................... 22
  2.3.5.4 Building a hybrid mesh ............................................................................... 22
  2.3.5.5 Insert drift(s) into an existing 3-D grid......................................................... 23
  2.3.5.6 Insert repository drifts in an existing 3D grid................................................. 23
  2.3.5.7 Dig repository out from an existing 3D grid................................................. 24
  2.3.6 Modification of an existing 3D grid ................................................................. 24
    2.3.6.1 Rock type assignment .................................................................................. 24
    2.3.6.2 Assign property by kind .............................................................................. 24
    2.3.6.3 LBNL Cell-Naming ...................................................................................... 25
    2.3.6.4 Reassign gravity .......................................................................................... 25
    2.3.6.5 Recalculate global XYZ of connections ...................................................... 25
    2.3.6.6 Remove all lateral connections .................................................................... 26
    2.3.6.7 Adjust D1 and D2 for lateral connections ................................................... 26
    2.3.6.8 Adjust D1 and D2 for vertical connections .................................................. 26
    2.3.7 Modification of an existing 2D cross section grid ......................................... 27
    2.3.7.1 Combining side cells vertically ................................................................. 27
    2.3.7.2 Splitting side cells horizontally ................................................................. 27
    2.3.7.3 Adjust thickness of 2D cross section ......................................................... 28
    2.3.8 Visually inspection ....................................................................................... 28
      2.3.8.1 Getting into plot mode ............................................................................... 28
      2.3.8.2 Select a view ............................................................................................. 28
      2.3.8.3 Select or unselect an object to view ............................................................ 29
      2.3.8.4 Display on map view ................................................................................ 29
      2.3.8.5 Zoom ....................................................................................................... 29
      2.3.8.6 Relocating the center of a view ................................................................. 29
      2.3.8.7 Drawing a straight line on a graph ............................................................ 30
      2.3.8.8 Adding, Deleting, Moving a label and editing its font ................................ 30
      2.3.8.9 Select a subset of a grid ............................................................................ 31
      2.3.8.10 Deselecting columns .............................................................................. 32
      2.3.8.11 Show selected subgrid (map view) .......................................................... 32
      2.3.8.12 Show a cross-sectional view of a selected profile ................................... 32
      2.3.8.13 Printing graphs ....................................................................................... 33
      2.3.8.14 Printing a graph to a disk file (EPS file) .................................................. 33
    2.3.9. Saving grid information (output files) ......................................................... 33
      2.3.9.1 Saving 3D Mesh file for TOUGH2 ............................................................ 33
      2.3.9.2 Saving 3D Mesh file for checking ............................................................. 34
      2.3.9.3 Saving 3D Mesh file for DualKGenerator .................................................. 34
      2.3.9.4 Saving 3D Mesh file for DCPT ................................................................. 34
2.3.9.5 Saving 3D MINC Mesh file ................................................................. 35
2.3.9.6 Save a subset of a 3-D mesh for TOUGH2 ........................................ 35
2.3.9.7 Save information of a subset of a 3-D mesh for quality checking ......... 36
2.3.9.8 Save selected mesh for dual-K grid generator ..................................... 36
2.3.9.9 Save a list of lateral connections through a selected profile ................. 37
2.3.9.10 Save a list of selected columns ............................................................ 37
2.3.9.11 Saving a mesh file of Boreholes for checking .................................... 37
2.3.9.12 Saving a mesh file of Boreholes for TOUGH2 .................................... 38
2.3.9.13 Saving a List of Fault columns ............................................................. 38
2.3.9.14 Saving a List of borehole columns ...................................................... 38
2.3.9.15 Saving a List of the columns west of a fault ....................................... 39
2.3.9.16 Saving a List of repository cells by Region ......................................... 39
2.3.9.17 Saving a List of repository cells by repository drifts ......................... 39
2.3.9.18 Saving the list of cells of a particular layer (including repository horizon) ................................................. 40
2.3.9.19 Saving a Segment file in a format compatible with Amesh .................... 40
2.3.9.20 Saving mesh files for Dual-permeability grid Generator ....................... 40
2.3.9.21 Saving mesh files for DCPT ................................................................. 40
2.3.9.22 Saving Ids of those source cells for DCPT ......................................... 41
2.3.9.23 Saving the bottom elevation of a user-selected layer in a binary file .... 41
2.3.9.24 Saving list of cells for each drift ......................................................... 41
2.3.9.25 Saving a list of boundary cells (top boundary of a polygon) .............. 41
2.3.9.26 Saving a list of boundary cells (bottom boundary of a polygon) ......... 42
2.3.9.27 Saving a list of internal boundary cells .................................................. 42
2.3.9.28 Saving a list of internal boundary cells (top only) ............................... 42
2.3.9.29 Saving a list of internal boundary cells (bottom only) ......................... 43
2.3.9.30 Saving a list of internal boundary cells (side only) ............................. 43
2.3.10. Tools ....................................................................................................... 43
2.3.10.1 Text Editor ............................................................................................. 43
2.3.10.2 Text column mixer ................................................................................. 44
2.3.10.3 Quality checking of 3-D cells ................................................................. 44
2.3.10.4 Quality checking of 3-D connections ..................................................... 44
2.3.10.5 Quality checking of overlapped columns ............................................ 45
2.3.10.6 Amend open polygons ........................................................................... 45
2.3.10.7 Remove nodes almost on the domain boundary ................................... 45
2.3.10.8 Find steep lateral connections ............................................................... 45
2.3.10.9 Find level vertical connections ............................................................... 45
2.3.10.10 Check consistency between vertical connections and the cell elevations ... 46
2.3.10.11 Remove redundant data points from fault files ................................. 46
2.3.10.12 Convert an ASCII file into a binary file ............................................... 46
2.3.10.13 Convert fracture property file .............................................................. 46
2.3.10.14 Search column ................................................................................... 47
2.3.10.15 Find rock composition of repository ................................................... 47
2.3.10.16 Preprocessing: Grouping Pulse ............................................................ 47
2.3.10.17 Preprocessing: Assign boundary conditions ....................................... 48
2.3.10.18 Preprocessing: Insert line sources ...................................................... 49
2.3.10.19 Preprocessing: Combine source files .................................................. 49
2.2. Outputs .......................................................................................................................... 68
2.3. Validation of the Grid .................................................................................................. 68
3. Case 3: A hybrid (partly single continuum, dual-permeability, and MINC) grid ........ 72
   3.1 Development of a hybrid grid .................................................................................. 72
   3.2 Validation of the hybrid grid ..................................................................................... 73
4. Case 4: Consistency between WINGRIDDER-generated grid and the repository geometry ................................................................................................................................. 74
   4.1 Grid development ...................................................................................................... 74
   4.2 Outputs ..................................................................................................................... 75
   4.3 Validation of the Grid ............................................................................................. 75
TABLES

Table 1: Specifications of the submesh BOX ................................................................. 7

FIGURES

Figure 1: The grid file generated using WINGRIDDER V3.0 for case 1 ( “…” represents the cells or the connections omitted in the figure ) .............................................................. 66
Figure 2: Interpolated Elevation Comparison for Ttpmn (elevation) ............................... 70
Figure 3: Elevation Difference between WINGRIDDER Interpolation and GFM 3.1 Interpolation (elevation) ....................................................................................... 70
Figure 4: Interpolated Elevation Comparison for Ttpmn (thickness) ............................... 71
Figure 5: Elevation Difference between WINGRIDDER Interpolation and GFM 3.1 Interpolation (thickness) ....................................................................................... 71
1. INTRODUCTION

1.1 PURPOSE

The objective of the User Information Document is to provide information to the end-user on how to effectively install and use the software referenced on the title page.

1.2 SOFTWARE IDENTIFICATION

This document contains the user’s information of the software identified on the title page.

The Software Configuration Control Request (SCCR) (Software Tracking Number [STN]: 10024-3.0-00) specifies the plan used to produce this document.

Requirements Document for WINGRIDDER Version 3.0 (Document ID: 10024-RD-3.0-00) specifies the requirements that the design implements.

Design Document for WINGRIDDER Version 3.0 (Document ID: 10024-DD-3.0-00) specifies the design and validation test cases.

1.3 DEFINITIONS

No additional definitions are provided.

1.4 TRACEABILITY

The Requirements Traceability Matrix (Document ID: 10024-RTM-3.0-00) documents the relationships between the following:

- The Requirements (as specified in the RD) and the design elements (as specified in the DD)
- The Requirements (as specified in the RD) and the validation test cases (as specified in the DD)
- The User Information Document (as specified in section 2) and requirements (as specified in the RD).
2. USER INFORMATION

2.1 INTRODUCTION

WINGRIDDER V3.0 is a Windows-based software for designing and generating numerical grids for numerical simulators that are based on the “integral finite difference” or the “control volume” numerical scheme (e.g., TOUGH2, Pruess et al., 1996). The user can design and generate grid that properly represents the stratigraphic features, inclined faults, and repository. WINGRIDDER V3.0 is an upgrade from WINGRIDDER V2.0. This revision includes testable requirements as listed in the Requirements Document (RD), 10024-RD-3.0-00, Section 2. With new features, WINGRIDDER V3.0 adds the ability to generate a multiple-interactive-continuum (MINC) grid.

2.2 HOW TO USE THIS SOFTWARE

WINGRIDDER V3.0 will be a Windows based application with graphical user interface. All functions will be accessible for the user by clicking the corresponding menu bars or buttons. All manual inputs will be entered through a textbox provided by the WINGRIDDER V3.0. WINGRIDDER does not limit the order of the dialogs between the user and the WINGRIDDER V3.0 in most case. However, the users shall not abuse this flexibility because it may result in crash of the software execution when the order is not logical in terms of grid generation. We strongly suggest the users to follow the steps described below in a hypothetical example.

The following description of user interactions is provided in a form of a hypothetical example. Before using the software, the user will be required to put all input files in a user-specified directory (the working directory). All input values and all filenames will be user-specified. The filenames or the input values provided below are just examples or placeholders. The hypothetical example is considered to be the best way to generate a grid using WINGRIDDER V3.0 for the user.

2.2.1 2D Grid (column scheme) Development

Double-click the application from Start Menu (Start → WinGriddner → WinGriddner.exe)
The “Gate of The Gate of WinGriddner” window asking about new or existing that first appears when WINGRIDDER is opened. For the first time, click “New” button on the window.

Step 1: Load lateral boundary information: Click File → Load → Bound (from the menu bar).
These files define the UZ Model domain and repository outline, respectively.
Click OK, the WINGRIDDER V3.0 will read the related data into the memory.
Step 2: Load fault information: Click File → Load → Faults from the menu bar.
Select all faults within the UZ Model domain, but not those coincidental with model boundaries (*.fut) from the file selection dialog box.
Click OK to initialize the loading.
Step 3: Load borehole information: Click File → Load → Borehole from the menu bar.
Select the file “BoreholeCoords.hol” from the file selection dialog box.
Click OK to initialize the loading. WINGRIDDER V3.0 will show the number of boreholes that have been loaded.

Click Ok on the dialog box.

Step 4: Load ECRB information: Click File ➔ Load ➔ Drifts from the menu bar.
Select file “ECRBpart.dft” from the file selection dialog box.
Click OK to initialize the loading.

Step 5: From the menu bar, select: Click Design ➔ 2D
Under the pull-down menu of “Select an Object” on the screen, choose Domainbound.
Enter a node spacing of 300 (meters) to the “Average Distance” textbox.
Pop-up windows appear:
Rectangular Mesh? Yes
Please enter Angle to Positive X: 0
Please enter the ratio of size: Y to X: 1
Under “Select an Object,” choose Repository.
Enter an “Average Distance” of 81 (meters).
Under “Select an Object,” choose partECRB.
Enter an “Average Distance” of 100 (meters).
Under “Select an Object,” choose All Faults.
Enter an “Average Distance” of 100 (meters).
A Set Fault Option window appears:
Click Default.
Edit MinDis, Width, or avgDis for any applicable faults in the table if necessary.
Click Ok after editing.
Under “Select an Object,” choose Boreholes.
Enter an “Average Distance” of 30 (meters).

Step 6: At this point, the location of certain nodal points created for each object (e.g., domain, repository, faults, and boreholes) could be modified (e.g., deleted, moved, or added) to achieve a desired nodal point array. The nodal array will be saved as: “UZ01.in”

Step 7: From the menu bar, select: Generate ➔ 2D
Load the file “UZ01.in.” The program will run and create the file “UZ01.grd.”

Step 8: Load the grid file “UZ01.grd” and remove any incorrect segments from the 2-D grid by selecting: Design ➔ Remove Bad Segments from the menu bar;
This targets fault segments, in particular; however, the user may also define a “minimum ratio” (i.e., the minimum value of the ratio of the segment length to the square root of the neighboring cell area) for a segment, so that any segment whose length is smaller than the product of this minimum ratio and the square root of the neighboring cell area will also be deleted from the grid. In this case, a minimum ratio of 5% can be specified.

Step 9: Save the 2-D grid: Click Project ➔ Save ➔ 2D from the menu bar;
Type the filename into the provided box if this is a new project. Otherwise, select a proper filename from the file selection box. The project is saved as “UZ01_2D.prj”

2.2.2 3D Grid Development

Step 1: Open WINGRIDDER3.0, Load lateral boundary information: Select files “Domain2001.bnd” and “Repo2001.bnd”, and then load the 2-D grid project: “Grid2001_2D.prj”
Step 2: From the menu bar, select Edit → Update Repo Columns

Step 3: From the menu bar, select: Generate → 3D → Cells/Vertical Cons Only

A window pops up and asks the user if they want to automatically save the project. For large projects (such as this one), select “Yes.” The project is named: “Grid2001_3D.prj”

Pop-up windows appear for which the following information is specified:
Use long LBNL name (8)? Select “Yes” (If no, default of 5 characters is used.)
(If you have not loaded geological layer information, the following windows will appear.)
Click OK on the dialog box of “No Layers! You should load layer data first!” if any.
Select “LayerList730” and then “Layer2001.roc”.
Do boreholes have their own layering information? No.
(End of loading layering information).

Please type in the MINIMUM thickness of a cell: 1.5 (meters)
Please type in the MAXIMUM thickness of a cell: 60 (meters)

A window of Set Layer Option will pop up.
Edit the minThickness and maxThickness for each layer and then click OK.

Do you want to have a locally dense grid for Repository? No

Step 4: From the menu bar select: Generate → 3D → Lateral Cons Only

A window pops up and asks the user if they want to laterally connect top cells and laterally connect bottom cells even if these cells belong to different layers? Select “No”

Please type in the MINIMUM thickness of a cell: 1.5 (meters)

The program runs and automatically saves the 3-D grid as: “Grid2001_3D.prj”

Step 5: From the menu bar, select File → Save → 3D mesh. The output TOUGH2 file created is called: “Grid2001_3D.mesh”

2.2.3 Development of a hybrid grid

Step 1: If WINGRIDDER V3.0 has not been opened (option 1):
Open WINGRIDDER V3.0 and click “Existing” button.
Double click the sub directory until “Case3” (i.e., the sub directory containing all the input files) is reached and then click “OK” button.
Select “Sample3D.bnd” and click “OK” button.

If WINGRIDDER V3.0 has already been opened (option 2):
From the menu bar, select: Project → Close
From the menu bar, select: Project → Get Directory
Double click the sub directory until “Case3” is reached and then click “OK” button.
Select “Sample3D.bnd” and click “OK” button.

Step 2: From menu bar, Select Project → Open and then select “Sample3D.prj” and click “Open” button.

Notes: If a warning of “This is a 2D project!” occurs, modify the path in the “Sample3D.prj” (using a standard text editor to open the file, roll down to the end of the file, modify the path as to be the directory where the file “Sample3D.mdb” resides, and save the modified file). Then try to open the project file again.
Step 3: From the menu bar, Select Generate →3D→MINC Mesh
Select “FRAMTR3.fp” and click “Open” button;
Enter 5 on the “Enter number of matrix cells” box and click OK.
On the window of “Define the sub-mesh BOX”:
Select “constant” for “TOP” and then enter “70” into the “Elevation of TOP” box
Select “None” for “Bottom”
Select “LoadedObject” for “Sides” and then select “Domainbound” for “Existing polygons”
Click “Validate”. If any error occurs, correct it accordingly and then click “Validate”
again until no error-warning window shows up.
Click OK.

Click OK on pop-up window showing “the MINC grid has been created successfully”

Step 4: Output the hybrid mesh file
From the menu bar, Select File->Save->3Dmesh->MINC
Select “Sample3D_MINC5_v.mesh” on the “Opening DBFilefile …” window and click
“Open” button
Enter “Hybrid_veri.mesh” in the File name box on the Saving Meshsfile …” window and
click “Save” button.
Click “No” on the pop-up window with a question of “Do you want to save index too?”

2.3 INTERACTIONS WITH THE SOFTWARE

2.3.1 Management of Projects

2.3.1.1 Creating a new directory/Getting in an existing directory

Purpose: To set the current working directory, all input and output files for a particular project
should be located in the same directory. Multiple projects can be put in the same directory, which
is recommended for convenience if these projects share the same input files (e.g., sharing the
same geological data file).

How:
Getting in an existing directory:
1. Click Project→GetDirectory on the menu bar
2. Select the appropriate driver and directory from the dialogue box;
3. Click Ok.
4. Select proper domain boundary file on the pop-up window and click OK

Creating a new directory:
1. Click Project→SetDirectory on the menu bar
2. Select the appropriate driver and directory from the dialogue box;
3. Enter the name of the new directory you want to create in the “Project Located at” box.
4. Click Ok.
5. Click Cancel on the pop-up window and then click OK on the warning pop-up Window “You Cancel opening file!”

**Tips:** When selecting a directory, make sure it shows up in the “Project Located at” box. Otherwise, its immediate parent directory may be selected as the current directory. The program will warn you about other errors (such as invalid directory names).

### 2.3.1.2 Opening an existing project

**Purpose:** To load information about an existing grid project, information about a project is actually stored in two files. One is a text file (project file), which contains information on all columns (2-D cells), segments, sub-segments (if any), project status, etc. The other is an Access database file comprised of three tables with information about 3-D cells, connections, and the neighborhoods of each cell.

**How:**
1. On the menu bar, click Project → Open;
2. Select the appropriate project file;
3. Click Open.

**Tips:** If the domain boundary file has not yet been loaded, a pop-up window with warning message such as “No Data of domain Boundary exist!! Please load it first.” will occur. If this is the case, click OK on the pop-up window and then click File → Load → Bound to load the domain boundary file.

### 2.3.1.3 Saving a project

**Purpose:** To save a grid project and keep all related information on disk files to avoid recreating the project from scratch. When saving a 2-D project, no Access database file will be created.

**How:**

*Save 2D or 3D mesh:*
1. On the menu bar, click Project → Save → 2D (or 3D)
2. Either select an existing project file on the file list (if you want to update the existing project file) or type a new file name in the file name box (if you want to save it as a new project)
3. Click the Save button.

*Save a submesh of the current grid as a separate grid project:*
1. On the menu bar, click Project → Save → SubMesh;
2. Either select an existing project file on the file list (if you want to update the existing project file) or type a new file name in the file name box (if you want to save it as a new project);
3. Click the Save button.
4. On the pop-up “Define the sub-mesh BOX” window, specify Top, Bottom, and Sides of the submesh box and then click Validate until no error warnings occur. Click Finish to complete the saving.

Table 1: Specifications of the submesh BOX

<table>
<thead>
<tr>
<th>Type</th>
<th>Follow up action</th>
<th>Description/Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top</td>
<td>None</td>
<td>N/A</td>
</tr>
<tr>
<td></td>
<td>Constant</td>
<td>Enter the elevation of the top into the text box</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>Enter the name of the file that describes the top elevations of the submesh</td>
</tr>
<tr>
<td></td>
<td>Top</td>
<td>The submesh has a top with spatially variable elevation. The filename can be</td>
</tr>
<tr>
<td></td>
<td></td>
<td>“repository” (requiring that the repository file has been loaded) or a single</td>
</tr>
<tr>
<td></td>
<td></td>
<td>layer filename (see Appendix A for the format of a single layer file).</td>
</tr>
<tr>
<td>Bottom</td>
<td>None</td>
<td>N/A</td>
</tr>
<tr>
<td></td>
<td>Constant</td>
<td>Enter the elevation of the bottom into the text box</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>Enter the name of the file that describes the bottom elevations of the submesh</td>
</tr>
<tr>
<td></td>
<td>Bottom</td>
<td>The submesh has a bottom with spatially variable elevation. The filename can be</td>
</tr>
<tr>
<td></td>
<td></td>
<td>“repository” (requiring that the repository file has been loaded) or a single</td>
</tr>
<tr>
<td></td>
<td></td>
<td>layer filename (see Appendix A for the format of a single layer file).</td>
</tr>
<tr>
<td>Sides</td>
<td>Hand Pick</td>
<td>A Selecting Columns window will occur after you click Finish button. You can</td>
</tr>
<tr>
<td></td>
<td></td>
<td>pick columns to define the side boundary of the submesh following the steps</td>
</tr>
<tr>
<td></td>
<td></td>
<td>described in Selecting Columns section.</td>
</tr>
<tr>
<td></td>
<td>Disk File</td>
<td>Enter a filename of a polygon file that defines the lateral boundary of the</td>
</tr>
<tr>
<td></td>
<td></td>
<td>submesh. All columns within the polygon will be included in the submesh.</td>
</tr>
<tr>
<td>Loaded Object</td>
<td>Select one object from the loaded area object list</td>
<td>If the domainbound is selected, entire mesh (in horizontal dimensions) will become the submesh.</td>
</tr>
</tbody>
</table>

**Tips:** Always save a project file with the default extension “.prj.” Always save a project as a 2-D project before generating a 3-D grid because the 2-D grid can be reloaded at any time as a basis for a 3-D grid with different options.

### 2.3.1.4 Closing a project

**Purpose:**
To unload an opened project from memory. This allows for initialization and generation of a new project.

**How:** On the menu bar, click Project ➔ Close.

**Tips:** If quitting WINGRIDDER, click Project ➔ Exit instead of Project ➔ Close.

### 2.3.2 Loading Input Files

#### 2.3.2.1 Domain boundary and subboundaries

**Purpose:**
To load the domain boundary file and generate an object that represents the model domain. Only the objects and processes within the domain boundary will be simulated. The data file describing the domain boundary should have the extension “.bnd.” It is a text file that starts with the keyword “Domainbound,” followed by the top elevation, the bottom elevation, and a series of (x, y) coordinates (see Appendix A for detailed descriptions of the format).

**How:**
1. On the menu bar, click File ➔ Load ➔ Bound;
2. Select the appropriate file to be loaded.
3. Click Ok to load the selected files, or click Cancel to cancel the loading.

**Tips:**
(a) Multiple files may be loaded at the same time. This is done in two ways:
   1. by holding down the Ctrl Key while selecting each file needed (this allows for selection of multiple files that are separated by unwanted files in the list), and
   2. by holding down the Shift Key while selecting multiple files in the list.

(b) Multiple boundary files represent multiple areas requiring node assignment with different configurations. However, among the boundary files selected, at least one and only one file should have the keyword “Domainbound,” which defines the simulation domain boundary. Furthermore, each file has to have a unique keyword or name. Any violations of these rules will result in failure to load, and WINGRIDDER will issue a warning. At any time, the boundary files can be reloaded to update information regarding boundary objects, and all previous boundary objects will be cleared from...
memory. Note that when starting WINGRIDDER, the program automatically asks for specification of the boundary files.

2.3.2.2 Repository

**Purpose:** To load the repository configuration files. A repository is a special kind of boundary object in WINGRIDDER.

**How:** see Section 3.1.2.1 Domain Boundary. Repository is a special boundary object and is loaded into the program with all other boundary objects together.

**Tips:** A repository can have multiple regions (See Appendix A for the format). Do not use the keyword “Repo” in any other files of “Boundary” objects unless that object is intended to be a repository. The interfaces of 3-D cells within the repository may not be located exactly at the interfaces of geological layers if they are not coincidental spatially, and the lateral connections may not be confined to within stratigraphic layers.

2.3.2.3 Faults

**Purpose:** To load fault data files.

**How:**
1. On the menu bar, click File ➔ Load ➔ Faults
2. Select the appropriate file(s) to be loaded from the file list
3. Click Open.

**Tips:**
(a) The default extension of the fault files is “.fut.” For details on selecting multiple files, see Tips in Section 2.3.2.1.
(b) Fault files can be reloaded to update the fault object information, and all previous fault objects will be cleared from memory. Do this to include a different number of faults than used in the previous iteration of a grid. When exiting WINGRIDDER, all fault objects are cleared from memory.

2.3.2.4 GeoLayers

**Purpose:** To load data describing stratigraphic structures and rock type distribution.

**How:**
1. On the menu bar, click File ➔ Load ➔ GeoLayers
2. Select the appropriate layer list file and click Open
3. Select the appropriate rock type file and click Open

**Tips:**
(a) The default extensions of the layer list file, the layer order file, and the rock type file are “.txt,” “.dat,” and “.roc,” respectively.
The user can reload the layer files to update the stratigraphic information, and all previous layer objects will be cleared from memory. When exiting WINGRIDDER, all layer objects are cleared from memory.

2.3.2.5 Drifts

**Purpose:** To load files describing the layout of drifts and other line objects.

**How:**
1. On the menu bar, click File ➔ Load ➔ Drifts;
2. Select the appropriate drift files from the list;
3. Click Open.

**Tips:**
(a) The default extension of the line object files is “.dft” or “.rvr.” Any line object can be formulated into this category. Examples are rivers, special rock bodies that have line-type shapes, borehole paths, or any line area requiring a different grid density from surrounding areas. For instance, a “dummy” line object is very useful for generating a grid for a cross-sectional profile. For details about how to select multiple files, see Tips in Section 2.3.2.1.
(b) Drift files can be reloaded to update the information of the drift objects and all previous drift objects will be cleared from memory. When exiting WINGRIDDER, all drift objects are cleared from memory.

2.3.2.6 Boreholes

**Purpose:** To load location information about vertical boreholes.

**How:**
1. On the menu bar, click File ➔ Load ➔ Boreholes;
2. Select an appropriate borehole file;
3. Click Open.

**Tips:**
(a) Borehole data are used for the assignment of nodes at exact coordinates corresponding to borehole locations in map view. Note that assignment of borehole nodes may conflict with the requirements of other special objects such as repositories and faults. If this is the case, the last assigned nodes would prevail.
(b) The borehole file can be reloaded to update the information about borehole locations, and all previous borehole objects will be cleared from memory. When exiting WINGRIDDER, all borehole objects are cleared from memory.

2.3.3 Column Design and 2-D Grid Generation (map view)

2.3.3.1 Getting in Design mode

**Purpose:** To prepare the working platform for column design and map-view grid generation.

**How:**
1. On the menu bar, click Design → 2D, and a design platform will show up on the screen;
2. Click the Display button located on the right side of the window to display a current view on the plotting board (the plotting board is located on the left side of the plot window). The domain boundary and outlines of other bound objects will be drawn on the board.

**Tips:** In design mode, the user cannot print a graph to a printer or a file. Printing can be done, however, by switching to plot mode (i.e., by clicking the Plot→View on the menu bar).

### 2.3.3.2 Assigning nodes for objects

**Purpose:** To assign nodes to represent each object. Assignment of nodes is the first step of column design. These nodes will be the basis for the column layout of a grid.

**How:**
1. Select DomainBound from the pull-down list of the available objects located in the top-right corner of the design window. The domain boundary will be highlighted by a thick line on the plotting board.
2. Specify the average distance between neighboring nodes in the Average Distance box.
3. Click the Add Nodes button. The following pop-up windows may occur:
   - “Rectangle Mesh ?” click Yes or No button:
     - If click Yes, “Please enter Angle to Positive X”: enter the angle (degree) between node orientation and the positive x-axis in the box and then click OK
     - “Please enter the ratio of size: Y to X”: enter the ratio of y-spacing over x-spacing in the box and then click OK
   - If click No, “Random” Click Yes or No button:
     - If click No, “Please enter Angle to Positive X”: enter the angle (degree) between node orientation and the positive x-axis in the box and then click OK
     - “Please enter the ratio of size: Y to X”: enter the ratio of y-spacing over x-spacing in the box and then click OK
   After answer these questions, WINGRIDER will generate nodes and display them on the plotting board as red dots. The current (total) number of nodes is shown on the status bar.
4. If the nodal array is unsatisfactory, click the Clean or Clean All button to delete nodes, and return to Step 2 to reassign nodes. Otherwise, continue. The Clean button deletes only those nodes that represent the object currently selected, while the Clean All button deletes all existing nodes.
5. To assign nodes to remaining objects within the domain boundary, select another object from the “Select and Object” pull-down list and follow Steps 2 through 4 above.

**Tips:** (a) The Clean All button deletes all existing nodes; therefore, nodes for the domain boundary must be reassigned before nodes for any other objects may be assigned. If the user wishes to delete only a few nodes, it should be done interactively.
(b) There is no special order, sequence, or requirement for assigning nodes to objects other than the domain boundary, which must be done first. Keep in mind, however, that nodes assigned later may delete the previous existing nodes if the nodes are located in close proximity.

(c) A node’s KIND property determines which object it represents. The KIND property is usually the name of the object that the node represents and can be later modified interactively. If a node is shared by multiple objects, its KIND property is the combination of the names of those objects.

(d) A fault is represented by three parallel rows of nodes. WINGRIDDER displays a fault with different colors: yellow for the fault nodes and green for the side nodes. A side node’s KIND property usually contains a keyword which consists of the fault node’s name and either “Side0” or “Side1,” depending on which side of the fault it is located. This designation allows a fault to be represented as a nonvertical column in a 3-D grid.

(e) A special “group object” exists for selecting similar objects and assigning nodes to them collectively instead of on an individual basis. For example, the user can select AllFaults instead of each fault individually. The order of node assignment is the same as that for loading objects. The group object for boundary objects is called Other Area Object.

(f) Selecting SingleNode from the “Select and Object” pull-down list allow the user to add a node Interactively by using the mouse and keyboard. For information about adding nodes interactively, see Section 2.3.3.3.

(g) Selecting FreeHandObjects from the “Select and Object” pull-down list allows the user to add several geometry objects, such as a line, a circle, and a polygon, interactively on the grid for plotting purposes only. Assigning nodes to these interactively added objects is not permitted in the current version of WINGRIDDER.

When the Average Distance box is active, pressing the Enter (or Return) key is equivalent to clicking the Add Nodes button.

2.3.3.3 Interactively adding node

Purpose: To add a node at an arbitrary location using the mouse and keyboard. This function complements the function of adding nodes for objects. It provides some flexibility for a user to design a column layout more suitable for representing complex simulation objects, especially when the objects overlap each other in space.

How:
1. Select SingleNode from the “Select and Object” pull-down list and click the Add Nodes button
2. Point the mouse (the mouse occurs as a “+” on the screen) to the location you want to place the node, the current x, y coordinates will be shown on the status bar of the main window;
3. Click the left button on the mouse while holding down the Ctrl-key on the keyboard.
4. You may also edit the KIND property assigned to a node (see Section 2.3.3.8).

Tips: (a) Use Zoom to get an enlarged view of the layout. If an interactively added node is not satisfactorily located, it may be modified by moving it or by deleting it using related
functionality. If the mouse is positioned outside the domain boundary, no node will be added because all valid nodes have to reside within the domain boundary.

(b) If an added node is too close to an existing node, WINGRIDDER will post a warning. The minimum distance criterion can be changed by entering a new value in the Average Distance box on the plot form when SingleNode is selected. However, the use of very small minimum distance values is not recommended because the 3-D grid generator will generate columns for all nodes, even if some of them exactly overlap each other. Tracking such an error may be difficult and very time-consuming.

2.3.3.4 Selecting a node

**Purpose:** To select a node as the current node.

**How:**
1. Point the mouse at the node to select;
2. Click the left button on the mouse while depressing the shift key. The selected node appears in blue.

**Tips:** Sometimes, a red line or box appears on the screen after a node has been selected. This is because moving the mouse with both the left button and the shift key down creates a durable red line on the graph. To erase this line, just draw another line on the screen (do not press the shift key) and click the Display button.

2.3.3.5 Cleaning nodes

**Purpose:** To delete unwanted nodes.

**How:**
- **Method 1** Click the Clean button. WINGRIDDER will delete all nodes that represent the object selected.
- **Method 2** Click the Clean All button. WINGRIDDER will delete all existing nodes.
- **Method 3** Draw a square that encloses all nodes to be deleted (see Zoom:Method 1 for how to draw a square on a graph); Press Delete on the keyboard.

**Tips:**
(a) Method 2 actually initializes your design work.
(b) When cleaning nodes, make sure neither the Grid box nor the Connection box is checked or an error message will appear.

2.3.3.6 Moving nodes to new locations

**Purpose:** To relocate an existing node.

**How:**
1. Select a node to be moved (see section 2.3.3.4 for how to select a node);
2. Point the mouse to the new location where the node should reside (see the status bar on the main window for new x, y coordinates);
3. Press the M-key on the keyboard. WINGRIDDER will show the node at the new location.

**Tips:** After a node is selected, it is in current status. Therefore, it can be moved multiple times without having to re-select it.

### 2.3.3.7 Viewing a node’s Name, LBNL name, and KIND

**Purpose:** To view a node’s Name, LBNLname, and KIND properties. A node’s Name is the internal ID for the node (or the column in the final 3-D grid), while the LBNLname is a conventional coded name for a column used by the LBNL UZ modeling group. For example, if the first letter of a LBNLname is upper case, this node represents a fault column. A node’s KIND property indicates to which object a node belongs.

**How:**
1. Point the mouse at the node for checking;
2. Press right button down to see the three properties. The first row of information contains the LBNLname with the node’s Name (internal ID) in parentheses, while the second row indicates the KIND property.

**Tips:** The node selected by WINGRIDDER is the one that is nearest to the mouse’s location.

### 2.3.3.8 Modifying the KIND of a node

**Purpose:** To assign or edit the KIND property of a node. The KIND property indicates which object a node belongs to and determines the kind of column to be generated for the node.

**How:**
1. Point the mouse at the node to be edited;
2. Click the right button on the mouse while holding the Ctrl-key down. A text box appears for editing the property;
3. Edit the KIND property;
4. Press the Enter key to end the editing.

**Tips:** Be careful when modifying a node’s KIND property to “Fault” because the whole column of cells generated for that node will be assigned fault rock properties.

### 2.3.3.9 Saving node information to a disk file

**Purpose:** To save a node file as input for the 2-D grid generator. Only x, y coordinates of nodes will be used in the 2-D grid generator, and the Names will be passed to the output files of the 2-D grid generator. The node file contains information about the domain boundary, and its default extension is “.in.”

**How:**
1. Click the Save button on the plot form;
2. Select a file from the list of existing node files; or
3. Type a new file name in the file name box;
4. Click Save to finish.

**Tips:** Selecting an existing file results in overwriting the file with new node information.
Warning: Not all node parameters will be saved in the node file. If you want to keep all parameters in a disk file, please use the saving project functionality (see Section 2.3.1.3).

### 2.3.3.10 Generating a 2-D grid

**Purpose:** To calculate a 2-D grid (layout of columns) for a given node file using Voronoi tessellation techniques. The results are written to a segment file and a cell file.

**How:**
1. On the menu bar, click Generate → 2-D;
2. Select a proper node file (".in") from a list of existing node files;
3. Click Open to initiate the work. A DOS window will show until the job is done.

**Tips:**
(a) Regenerate a 2-D grid whenever nodes have been added or deleted. Note that any unsaved modifications to the segments or connections will be lost after grid regeneration.  
(b) WINGRIDER may post a warning if it cannot find the executable file for the 2-D grid generator. If this is the case, check to see that the WINGRIDER software has been properly installed on your PC. The executable file for the 2-D grid generator is the modified Amesh code compiled by MS Developer Studio version 5.0 (written in C++). Note that the original version of Amesh will not work here.

### 2.3.3.11 Loading a 2-D grid into memory

**Purpose:** To load the primary 2-D grid. WINGRIDER first reads the information about segments and places this information into a segment collection (an internal object used as a warehouse to store all segments), and then updates the information describing the area and the neighborhoods of all columns.

**How:**
1. On the menu bar, click File → Load → Grid
2. WINGRIDER will post a warning if a grid file already exists in memory
3. Select an appropriate segment file (extension ".grd") from a list of available segment files
4. Click Open to initialize loading; WINGRIDER will specify how many segments have been loaded.

**Tips:**
(a) After loading the 2-D grid into memory, modifications may be made to the segments or connections in the 2-D grid, as necessary. Remember to save and regenerate the modified 2-D grid before continuing on to 3-D grid generation, or the modifications will be lost. Another way to access a 2-D grid is to open the corresponding 2-D project, which should be saved after completion of the 2-D grid design (column scheme).
(b) Before loading a new grid into memory, any existing grids in memory must first be unloaded. To do this, go to File→Unload→Grid.
2.3.3.12 Select a connection or a segment

Purpose: To select a segment as the current one. In the column layout, selecting a segment is equivalent to selecting a connection. A segment may be either moved or deleted after it is selected.

How:
Select two adjacent nodes consecutively. The color of the selected nodes will change to blue, indicating that the segment between these nodes is selected.

Tips: To see if two nodes are connected, check the Connection box in the Design window and click the Display button. If two selected nodes are not connected, no segment is selected. WINGRIDDER only remembers the last two selected nodes.

2.3.3.13 Interactively delete unwanted segments

Purpose: To delete unwanted segments interactively to enforce rules regarding the connections within a fault, repository, or other object. After removing a segment, all columns and segments that are affected will be recalculated and updated accordingly.

How:
1. Select a segment (see Section 2.3.3.12 for how to select a segment);
2. Press the Delete key while holding the Shift key down. If the selected segment does not exist (e.g., two selected nodes are not connected), the warning message “Can’t remove this segment!” will appear.

Tips: A segment cannot be removed if it is either:
(1) A part of the domain boundary; or
(2) A segment whose neighboring column only has three (lateral) sides.
If you try to delete one of these types of segments, WINGRIDDER will issue a warning and the segment will not be deleted.

2.3.3.14 Interactively moving a segment

Purpose: To change the relative position of a segment between two nodes. The Voronoi tessellation used in Amesh (the 2-D grid generator) always places a segment midway between two neighboring nodes. In some situations, however, this may not be desirable. For example, a user may want a node located in the center of the column. After moving a segment, all affected columns and segments will be recalculated and updated accordingly. The selected segment only shifts a given distance along the connection line between two neighboring nodes without changing its length. All other segments connected to the selected segment will be adjusted accordingly by WINGRIDDER, to preserve the connections. Thus, the affected columns may not be limited to the two neighbors of the selected segment.

How:
1. Select a segment (see Section 2.3.3.12 for how to select a segment);
2. Click Edit on the menu bar and then click Move Segment;
3. Type a relative distance into the input box;
4. Click OK and WINGRIDDER will perform all related calculations.

**Tips:** The relative distance is defined as a fraction of the distance between two neighboring nodes, while the sign (“+” or “-”) indicates the direction of movement.

### 2.3.3.15 Adding other objects (lines, circles, and polygons)

**Purpose:** To add objects interactively for special node assignments or for simply drawing geometry objects on the graph.

**How:**
1. Select FreeHandObjects from the “Select and Object” pull-down list
2. Click Insert
3. Select an object type and assign a name and drawing-width (or radii for a circle) to the object on the new object properties form.
4. Click Ok to start creating the new object. WINGRIDDER will provide instruction about how to create an object of the specific type selected.

There are three types of objects you can create:
1. *A line:* Point the mouse to the starting position of a line;
   Press the space bar to start creating;
   Move the mouse with left button down to draw a line;
   Press the space bar to confirm the end of a segment;
   Click Insert to modify the width of the line at any time;
   Press the Enter key to confirm the end of the line.
2. *A circle:* Point the mouse to the location where the center of the circle should be placed;
   Press the space bar until a circle appears on the board;
   Click Insert to modify the radius of the circle as needed;
   Press the Enter key to accept the circle.
3. *A polygon:* Point the mouse to the starting position of the polygon;
   Press the space bar to start creating;
   Move the mouse with left button down to draw a line;
   Press the space bar to confirm the end of a segment, WINGRIDDER will add the last segment automatically.
   Press the Enter key to accept the polygon.

**Tips:** The current version of WINGRIDDER allows these objects to be created as graphic objects only (i.e., WINGRIDDER does not allow these objects to be assigned nodes). If such objects require the assignment of nodes, proper input files should be created for them.
2.3.3.16 Deleting unqualified segments

**Purpose:** To delete any unqualified segments (i.e., the fault related segments that do not meet the requirements, or the segments that are too short compared to the areas of their neighboring columns).

**How:**
1. On the menu bar, click Design → Remove bad Segments;
2. Type an appropriate minimum ratio of the segment length over the column area;
3. WINGRIDDER will post a warning and abort removing segments if it finds an invalid segment; otherwise, it states how many unqualified segments have been removed.

**Tips:**
(a) The ratio of the segment length over the column area is calculated as the square of the segment length divided by the area of the adjacent column.
(b) Invalid segments are most likely fault-related segments. If so, first check the arrangement of fault-related nodes; specifically, whether or not the KIND properties of side nodes match the corresponding fault nodes. WINGRIDDER announces an error if it finds either of following two conditions:
   (i) A segment with zero length;
   (ii) A column whose area is less than or equal to zero.

2.3.4 Preparation and modification before 3-D gridding

2.3.4.1 Design vertical layer structure

**Purpose:** To set layer files for defining the simple stratigraphic structure (i.e., only level layer interfaces exist). This function is designed to provide an easy way for the user to prepare the layer files for the cases where all geological layers are horizontal.

**How:**
1. Click Design → Vertical structure.
2. Specify the parameters of geological layer data mesh: X0 (minimum x), Y0 (minimum y), X1 (maximum x), Y1 (maximum y), DX (data spacing along x-direction), and DY (data spacing along y-direction).
3. Enter filenames for LayerList Filename and LayerOrder Filename, respectively.
4. Click Edit Vertical Configuration.
5. On the pop-up “Edit Vertical Configuration” window, enter or edit proper parameters (layer name, data type, elevation, DZ, and rock name) for each layer (each layer occupies one row).
6. Click OK on “Edit Vertical Configuration” window.
7. Click OK on the window follows.

**Tips:**
(a) The layer names must be unique whereas the rock names can be arbitrary but must be 5 characters (TOUGH2 requirement).
(b) Among all layers, the three special layers, “top”, “refer”, and “bottom”, cannot be omitted and must use fixed name and their data type must be “elevation”. In addition, the
elevation of the “refer” layer must not be larger than that of the “top” layer and not be smaller than that of the “bottom” layer.

(c) If the thickness of a layer is larger than the user-specified “DZ”, this layer will be split into multiple layers in the layering structure. However, don’t confuse this “resolution” with the grid resolution that will be specified in 3-D grid generation.

(d) The “DZ” items for “top”, “refer”, and “bottom” layers can be omitted (default). If a non-zero value is assigned, the corresponding layer will be inclined along x-direction with the maximum difference in elevation equals to DZ. A positive DZ indicates that the elevation increases with x and vice versa.

2.3.4.2 Correcting singular side column

**Purpose:** To automatically remove the keyword “Side” from the “KIND” property of the column that is not associated with a proper “Fault” column. Any column marked as “Side” column must be associated with a proper “Fault” column to facilitate the special treatment in creating 3-D cells for fault related columns. Otherwise, it will cause troubles in 3-D grid generation.

**How:**
1. Click Design→CorrectSinularSideColumns.
2. Click OK on the pop-up window that shows how many singular side columns found and corrected.

2.3.4.3 Update repository columns

**Purpose:** To mark any repository column based on the currently loaded repository object. Two types of criteria will be used in determination of a repository column: (1) By Region (any column will be marked as a repository column if its representative node is located within the boundary polygons of a repository), and (2) By Drifts (any column will be marked as a repository column if it overlaps one or more repository drifts).

**How:**
1. By Region: Click Edit→Update Repo Columns→By Region
2. By Drifts: Click Edit→Update Repo Columns→By Region

The program will show the progress bar and then show the map view of the grid with larger dots plotted to mark the repository columns.

**Tips:** Criterion II (By Drifts) can only be used when the loaded repository object has individual drifts defined. Otherwise an error message “Error: No type II repository has been loaded! Your repository has to be type II (including drift information)” will occur. If this is the case, click Ok on the pop-up windows. Then either use By Region or load a new repository object that has drift information.
2.3.4.4 Remove word from column property

**Purpose:** To delete a user-specified phrase from ‘KIND’ or ‘GrandParent’ property.

**How:**
1. Click Edit→RemoveWordfromKind.
2. Enter the phrase you want to delete in the pop-up window and click OK.
3. Enter the name of the column property (either ‘Kind’ or ‘GrandParent’) and click OK.
4. Enter the condition phrase (i.e., The delete action will be effective only for those columns whose selected property containing the condition phrase) and click OK.

**Tips:** (a) The default condition phrase is empty (i.e., all property specified in Step 3 will be affected). Note that empty phrase means zero length of the string and it is different from a phrase contains one or more spaces.
(b) If you want to delete all contents in the selected property, enter “Delete all” in Step 2.

2.3.4.5 Add word to column property

**Purpose:** To add a user-specified phrase to ‘KIND’ or ‘GrandParent’ property.

**How:** Same as above (see Section 2.3.4.4)

**Tips:** see Tips 1 in Section 2.3.4.4.

2.3.4.6 Assign ‘KIND’ property based on regions

**Purpose:** To add the name of a region as a phrase to a column’s ‘KIND’ property if the column is located within the region except those fault-columns (i.e., its ‘KIND’ property containing the keyword ‘Fault’). A region is a polygon defined in boundary files (*.bnd).

**How:** Click Edit→Update Columns’ KIND as Region

**Tips:** This function only attaches the name of a region to the ‘KIND’ property of the qualified column. If you want to overwrite the property, use steps in Section 2.3.4.4 with “delete all”.

2.3.5 Generating 3-D Grid

Once the 2-D grid (map view) has been prepared, the user can generate the 3-D grid with several options. Generating a 3-D grid may require substantial CPU time, especially if the grid contains a large number of cells and connections. Therefore, WINGRIDDER allows the user to generate different components of the grid individually, if necessary.

2.3.5.1 Building cells and vertical connections only

**Purpose:** To generate cells and corresponding vertical connections for a given layout of columns and segments.
**How:** From the menu bar, select: Generate $\rightarrow$ 3D $\rightarrow$ Cells/Vertical Cons Only
Click Yes if a window pops up with a question “3D Grid or 3D cells exist!! Are you sure you want rebuild?” Otherwise go below.
A window pops up and asks “Do you want to save the project automatically?” Click “Yes” button. Then enter a filename for the project in the Saving Projectfile window and click “Save”.
Pop-up windows appear for which the following information can be specified:
“Use long LBNL name (8)?” Click “Yes” (8 characters will be used) or “No” (5 characters will be used) button.
“No layers! You Should load layer data first!”: click “OK” button.
Select the layer list file (e.g., “LayerList.txt”) in the Open File window and click “Open” button.
Select the rock file (e.g., “UZ99.roc”) in the Open File window and click “Open” button.
“Please type in the MINIMUM thickness of a cell. A layer that has thickness smaller than this value will be ignored!”: enter a value (e.g., 0.01) and hit Enter.
“Please type in the MAXIMUM thickness of a cell. A layer that has thickness larger than this value will be subdivided!”: enter a proper value (e.g., 20) and hit Enter.
Click “Default” and then “OK” button on the Edit Layer option window. If you want to have different resolutions for different layers, you can edit the values in the table before click OK.
“Do you want to have a locally dense grid for the Repository?” Click “No” button or “Yes” button at your selection. WINGRIDDER will create 3-D cells and vertical connections.

**Tips:**
(a) If the grid involves a large number of cells, use the option of automatically saving the project to enhance the performance of WINGRIDDER.
(b) If any required information is not ready (e.g., no layer data exist), WINGRIDDER will post a warning before generating the 3-D grid. If this is the case, click Ok and follow the instructions on the screen to load the necessary information.

### 2.3.5.2 Building lateral connections only

**Purpose:** To create lateral connections (except top/bottom connections) once the 3-D cells are created. The lateral connections are created segment by segment according to the rules described in Section 3.

**How:** From the menu bar select: Generate $\rightarrow$ 3D $\rightarrow$ Lateral Cons Only
Response to pop-up windows as following:
“Please type in the MINIMUM thickness of a cell. A layer that has thickness smaller than this value will be ignored!”: enter a proper value (e.g., 0.01) and hit Enter.
The program runs and automatically saves the 3-D grid.

**Tips:** (a) This functionality always saves the project automatically and should be used only after the 3-D cells have been successfully generated. If the 3-D cells have not already been generated, WINGRIDDER will post a warning and abort the process.
(b) The value of minimum cell thickness provided here (for lateral connections) has no effect on the minimum cell thickness specified in Section 2.3.4.1 (for building 3-D cells and vertical connections).

2.3.5.3 Building the full 3-D mesh

**Purpose:** To create a 3-D grid for a given layout of columns and segments (2-D grid) with related information. This is

**How:**

From the menu bar, select: Generate → 3D → Full mesh

A window pops up and asks the user “Do you want to save the project automatically?”: Click “Yes” button or “No” button according to your situation.

If “Yes”, enter project filename.

Pop-up windows appear for which the following information can be specified:

“No layers! You Should load layer data first!”: click “OK” button.

Select a layerlist file (e.g., “LayerList.txt”) in the Open File window and click “Open” button.

Select a rock file (e.g., “LayerList.roc”) in the Open File window and click “Open” button.

“Use long LBNL name (8 characters)?”: Click “No” button (use 5 characters) or “Yes” button (use 8 characters).

“Please type in the MINIMUM thickness of a cell. A layer that has thickness smaller than this value will be ignored!”: enter a proper value and hit Enter.

“Please type in the MAXIMUM thickness of a cell. A layer that has thickness larger than this value will be subdivided!”: enter a proper value and hit Enter.

Click “Default” and then “OK” on the Edit Layer option window. If you want to specify different resolutions for different layers, you can edit it in the table before click “OK” to finish the specification.

“Do you want to have a locally dense grid for the Repository?” Click “No” button or “Yes” button.

**Tips:** This function is a combination of “Building 3-D cells only” and “Building lateral connections only”. With this function, WINGRIDDER performs both jobs (in sequence) automatically. Note that this may require substantial CPU time. Therefore, it is important to make sure that the 2-D grid, or the layout of columns and segments, is satisfactory before generating a 3-D grid.

2.3.5.4 Building a hybrid mesh

**Purpose:** To build a hybrid grid (partly single continuum, dual-permeability, and MINC) for representing fractured porous media.

**How:**

From the menu bar, Select Generate → 3D → MINC Mesh

Select fracture property file (e.g., “FRAMTR3.fp”) and click “Open” button;

Enter the number of matrix cells (e.g., 5) on the “Enter number of matrix cells” box and click OK.
On the window of “Define the sub-mesh BOX”:
Define the “TOP”, “Bottom”, and “Sides” of the sub-mesh box within which a MINC mesh will be created except for the layers that are defined as dual-k only in the fracture property file. The following is an example of how to define the sub-mesh box:
Select “constant” for “TOP” and then enter “70” into the “Elevation of TOP” box
Select “None” for “Bottom”
Select “LoadedObject” for “Sides” and then select “Domainbound” for “Existing polygons”
Click “Validate” after finish specification. If any error occurs, correct it accordingly and then click “Validate” again until no error-warning window shows up.
Click OK.
Click OK on pop-up window showing “the MINC grid has been created successfully”

Tips:  
(a) The dual-K mesh is a special case of a MINC mesh where only one matrix cell is used.
(b) A pure dual-K mesh or MINC mesh can be generated by defining the sub-mesh box as no-top and no-bottom box with the sides defined as the entire domain boundary (select Loaded object and then select DomainBound).
(c) If a rock has zero fracture porosity as defined in the fracture property file, the program will leave those cells with such rocks as single continuum mesh.
(d) If the keyword for a rock in the fracture property file is “D”, the program will create
(e) If you want to create a MINC mesh without any global matrix connections, you can create the mesh follows the steps above and then select double-porosity type in saving MINC mesh file for TOUGH2.

2.3.5.5 Insert drift(s) into an existing 3-D grid

Purpose: To create a sub-mesh for a drift or a group of drifts and insert it into an existing 3-D grid. WINGRIDDER will first find those cells that are intersected with a drift as “host” cells and then split the original cell into a host cell and a drift cell. In the final grid, a drift cell is connected to its host cell and any adjacent drift cells.

How:
1. Click Generate→3D→Insert Drifts
2. Select a drift file and click Open
3. Click OK on the message box “Successfully inserted the drift!”

Tips: Be careful on the relative size of a drift (e.g., its radii) over a grid cell. Make sure that the volume of a resulted drift cell will be less than the volume of the original host cell.

2.3.5.6 Insert repository drifts in an existing 3D grid

Purpose: To create a sub-mesh for repository drifts and insert it into an existing 3-D grid. This function is very similar to the function described in Section 2.3.5.5. The difference is that the drifts here are defined in a type II (multiple regions) repository file.

How: Click Generate→3D→Insert Repo Drifts
Tips: A type II repository file must be loaded before start to do this job.

2.3.5.7  Dig repository out from an existing 3D grid

Purpose: To create a hole in the mesh to represent the repository with internal boundary cells. All cells within the repository box will be removed and internal boundary cells will be attached to the wall.

How: Click Generate → 3D → Dig Repo out

Tips: The resolution of the 3D grid must be less than the size of the repository.

2.3.6  Modification of an existing 3D grid

2.3.6.1  Rock type assignment

Purpose: To assign each cell with a 5-character rock name (i.e., material assignment) according to the rock-layer information provided in the layer files. Fault cells will have a rock name consisting of the first three letters of the rock name of the corresponding layer and the fixed term “fl” to indicate fault rock.

How:
1. On the menu bar, click Edit → Assign Properties.
2. If the layer information is not ready, WINGRIDDER will post a warning and ask the user to load the layer information.

Tips: Rock type assignment is usually done when the 3-D grid is created. This functionality is designed to offer the user an opportunity to modify rock properties without regenerating the 3-D grid, which can be time consuming.

2.3.6.2  Assign property by kind

Purpose: To assign a 5-character rock name (i.e., material assignment) for each cell. However the rock name is the first 5 letters of the KIND property of the column to which the cell belongs. As a result, the cells within the same column will have the same rock. There is one exception that the rock names of the fault cells will not be changed by this function.

How: On the menu bar, click Edit → Assign Properties by Kind.

Tips: This functionality is designed to offer the user a simple way to assign rock properties based on regions without using the complicated layer files with multiple rock regions. However, this function can be used only if the rock changes in horizontal direction only. In many cases, you may need use steps described in Sections 2.3.4.4 and 2.3.4.6 to assign proper KIND property for each column.
2.3.6.3 LBNL Cell-Naming

**Purpose:** To assign each cell with a unique LBNL cell name and each column a unique LBNL column name. The LBNL names are coded names used by TOUGH2 family codes. An LBNL column name consists of a letter and two digits. If the letter is capitalized, the column is a fault column. A LBNL cell name is created by adding two (or four, for the 8-character LBNL name option) letters from a layer name (i.e., the default rock name) before the column name. If multiple cells exist within a column for a single layer (i.e., the layer’s thickness exceeds the user-specified maximum cell thickness and has therefore been split into multiple cells), the last letter of the letters representing the layer will be replaced by ordered ascii characters. The first character of the 8-character LBNL name is empty (a place holder for indicating a fracture or matrix cell in a dual-K or MINC mesh).

**How:**
1. On the menu bar, click Edit → LBNL Naming;
2. If the layer information is not ready, WINGRIDDER will post a warning and ask the user to first load the layer information. If the name length has not been assigned, WINGRIDDER will ask for specification.

**Tips:** The LBNL names are assigned when a 3-D grid is generated. However, this functionality can be used to modify these names (e.g., switch from a long name to a short name). If 3-D cells are not ready, WINGRIDDER will post a warning and abort the process.

2.3.6.4 Reassign gravity

**Purpose:** To recalculate and update cosZ for each connection. The term cosZ is the cosine of the angle between the direction of a connection and the gravity direction. TOUGH2 code uses cosZ of a connection to calculate the gravity component for that connection.

**How:** On the menu bar, click Edit → ReassignGravity(cosz)
Enter ‘x’, ‘y’, or ‘z’ in the pop-up box to indicate the intended gravity direction and then click OK.

**Tips:** This functionality is designed to offer a simple way to turn a 3-D grid. When a 3-D grid is generated, the default gravity direction is z. However, in some situation, one needs to create a 3-D grid that has more complicated geometry in the vertical plane than in the horizontal plane. If this is the case, one can easily design the complex grid on x-y plane first and generate a 3-D grid normally, and then use this function to turn the grid to have the right gravity term.

2.3.6.5 Recalculate global XYZ of connections

**Purpose:** To recalculate and update XYZ coordinates for each connection as the average coordinates of the neighboring cells that are connected by the connection.

**How:** On the menu bar, click Edit → ReCalculate Global XYZ of Faces
Click Yes or No button to the question: “Only calculate Fault related faces?” based on your situation.

**Tips:** TOUGH2 code does not use XYZ coordinates in simulation. However, this information is saved in the mesh file for plotting purpose.

### 2.3.6.6 Remove all lateral connections

**Purpose:** To delete all lateral connections from a 3-D grid. The resulted 3-D grid will only contain cells and vertical connections (i.e., connection along z-direction).

**How:** On the menu bar, click Edit → CleanSideConnection

**Tips:** This function erases the effects of Generate→3D→Lateral Cons Only (Section 2.3.5.2).

### 2.3.6.7 Adjust D1 and D2 for lateral connections

**Purpose:** To adjust D1, D2, and interface area for all inclined lateral connections by a factor of $\frac{1}{\sqrt{1-(\cos Z)^2}}$ if there is any lateral connection whose D1+D2 is different from the real distance between the two neighboring cells by 1% or more.

**How:**
- On the menu bar, click Generate→3D→AdjustLConnections
- Click No to the question: “Are you sure you want to adjust the length of the inclined lateral connections?” to cancel the action. Click Yes to continue.
- If WINGRIDDER cannot find any qualified connections or failed to complete adjustment for any reason, a pop-up window with error message will appear and click OK on the pop-up window. Otherwise a message: “Adjusting the length of lateral connections completed” will appear when the job is done.

**Tips:** This function is used to avoid trouble in some rare situation where the lateral connections are so inclined that the original D1 and D2 calculated based on the segment on the x-y plane are no longer valid. An example of such situation is that huge offset across a fault exists in the layer data but the fault itself is not explicitly represented in the grid. As a result, the cells within the same layer across the fault will be connected together no matter how huge the difference in their elevation.

### 2.3.6.8 Adjust D1 and D2 for vertical connections

**Purpose:** To adjust D1 and D2 for all incline vertical connections by a factor of $\frac{1}{\cos Z}$ if there is any vertical connection whose D1+D2 is different from the real distance between the two neighboring cells by 1% or more.
How:
On the menu bar, click Generate → 3D → AdjustVConnections
Click No to the question: “Are you sure you want to adjust the length of the inclined vertical connections?” to cancel the action. Click Yes to continue.
If WINGRIDDER cannot find any qualified connections or failed to complete adjustment for any reason, a pop-up window with error message will appear and click OK on the pop-up window. Otherwise a message: “Adjusting the length of vertical connections completed” will appear when the job is done.

Tips: This function is used to avoid trouble in some rare situation where the vertical connections are so inclined that the original D1 and D2 calculated based on the elevation difference are no longer valid. An example of such situation is that the vertical connections between cells representing an inclined fault could be way off from the vertical direction.

2.3.7 Modification of an existing 2D cross section grid

2.3.7.1 Combining side cells vertically
Purpose: To combine side cells (i.e., the cells adjacent to fault cells) in a 2D cross section grid if they are too thin and belong to the same layer.

How:
1. On the menu bar, click Edit → Combine Side Cells vertically.
2. Enter a number for the maximum thickness if the pop-up window appears (the thickness of any combined cell will not exceed this value).

Tips: This job must be completed before splitting the side cells and only can be used for 2D cross section grid. Otherwise, an error message will appear and nothing will be completed.

2.3.7.2 Splitting side cells horizontally
Purpose: To split side cells (i.e., the cells adjacent to fault cells) in a 2D cross section grid if they are too wide.

How:
1. On the menu bar, click Edit → Split Side Cells horizontally.
2. Enter a number for the length of a standard cell if the pop-up window appears (any side cells with a width wider than this value will be split).
3. If layer files have not been loaded, WINGRIDDER will ask you to load layer files and follow the steps for loading layer files.
4. Enter 5 or 8 if a pop-up window: “Please input the length of LBNLName (5 or 8)?” appears.

Tips: This job can only be used for 2D cross section grid.
2.3.7.3  **Adjust thickness of 2D cross section**

**Purpose:** To adjust the thickness of a 2D cross section to a user-specified thickness by modifying the volumes of all cells.

**How:**
1. On the menu bar, click Edit → Adjust thickness of 2D cross section.
2. Click Yes on the pop-up window (Click No if you want to abort the task).
3. If you have not loaded a grid project, a pop-up window will occur. Click OK on that window and follow the instruction on the screen to load a proper grid project.
4. Click Yes on the pop-up window “Is this a 2D cross section grid?” (Click No if you mistakenly loaded a non-2D cross section grid and the task will be abort).
5. When a pop-up window “Please select a representative column using your mouse” occurs, Click OK and then pick a representative node (move your mouse to the node you want to select, hold Shift key down and click the left button on your mouse).
6. The program will show you the node spacing value and ask you if this is the node spacing in a pop-up window. Click Yes if it is right and click No if it is not.
7. If you click No on Step 6, a pop-up window will occur, and enter the correct node spacing value (must be positive) in the box. Otherwise go to next step.
8. Enter a new thickness value in the box on a pop-up window that also shows the current thickness calculated from the cell volume and the node spacing.

**Tips:** This function can only be used for a 2D cross section grid. All cell volumes and all interface areas will be modified by multiplying the ratio of new thickness over the current thickness. If any error occurs in the process, a warning message will occur.

2.3.8  **Visually inspection**

2.3.8.1  **Getting into plot mode**

**Purpose:** To make WINGRIDDER ready for plotting graphs.

**How:** Click Plot → View on the menu bar. A plot form will appear on the screen. The default plotting plane is map view.

**Tips:** In the plot mode, you cannot modify the grid such as assigning nodes for a specific object or delete/add a node. To assign nodes to objects, switch to design mode by clicking Design → 2D on the menu bar.

2.3.8.2  **Select a view**

**Purpose:** To select either a map view or cross sectional view.

**How:** Pull down the list of views from the “Select a plot plane” window located in the upper right corner of the plot form, and select one of them.

**Tips:** The default view in plot mode is map view. To view a grid in cross section, select a row of columns and then select cross section view.
2.3.8.3  Select or unselect an object to view

**Purpose:** To help users plot graphs with different combinations of objects.

**How:** Click the check boxes corresponding to the objects intended for display. An object may be either a grid object (i.e., Cells) or a geologic object (i.e., Faults).

**Tips:** WINGRIDGE automatically checks the availability of objects, and only the available objects will be activated for selection. The domain boundary and other area objects (e.g., a repository) will always be shown on the graph if they are available.

2.3.8.4  Display on map view

**Purpose:** To show a map view of a grid object or geologic object on the screen.

**How:**
1. Select Map view from the “Select a plot plane” pull-down list;
2. Select all objects to be included in the graph;
3. Click Display. A graph will be shown on the left part of the plot form.

**Tips:** Modify the graph by selecting different objects, and then click the Display button. Different parts of the graph may be plotted, with different scales, by using the Zoom or Relocating functions.

2.3.8.5  Zoom

**Purpose:** To plot a graph at different scales.

**How:**
Method 1. Move the mouse to a corner of the rectangle that you want to show Press the left button of the mouse; Move the mouse to the opposite corner of the rectangle with the left button down Release the button and a rectangle will be drawn on the graph; Click Zoom button and a zoomed graph will be plotted on the plotting board.
Method 2. Click Zoom button until a dialog window occurs; Type the coordinates of the left-bottom and the right-top corners of the plotting rectangle into the proper cells on the spreadsheet to zoom the graph into your specified dimensions, or click Default button to return to the default zoom status; Click the Ok button. A zoomed graph will appear on the plotting board.

**Tips:** You can zoom a graph of map view regardless of the mode (i.e., Design mode, Plot mode, or Select mode). However, Method 1 of the zoom function is not available if a graph is a cross-sectional view.

2.3.8.6  Relocating the center of a view

**Purpose:** To plot a different part of the graph with the same scale.
How:
Method 1. Point the mouse to a location that is the new center you want;
   Double click the left button. A new view of the graph will occur.
Method 2. Press one of the Arrow keys on your keyboard. Each press will shift the view by
   20% to the direction of the Arrow key you pressed.

Tips: You can relocate the center of a view regardless of the mode (i.e., Design mode, Plot
   mode, or Select mode). However, this function is not available if a graph is a cross
   section view.

2.3.8.7 Drawing a straight line on a graph

Purpose: To add a straight line to a graph. The line may indicate the location of a profile.

How:
1. Point the mouse to the starting position of the line;
2. Move the mouse with both the left button and the Shift key down.

Tips: To erase the line, move the mouse with the left button down only and then click the
   Display button.

2.3.8.8 Adding, Deleting, Moving a label and editing its font

Purpose: To add a text label at the specific location on a graph with various fonts.

How:
1. Adding:
   Click Add Label(s) button. A dialog box will appear to ask you if you want to add labels
   automatically (if it is the first label to add). If you click Yes, WINGRIDDER will create
   labels for each objects loaded. All the created labels are located at the top left corner of
   the plotting board. You can move these labels one by one to arrange them properly.
   Otherwise, WINGRIDDER will ask you to type the text you want the label to have.
2. Moving:
   Point the mouse to a label;
   Press the left button down and hold;
   Move the mouse to the location where you want to put the label;
   Release the left button.
3. Deleting:
   Move a label to the lower-left corner of the graph  (the area below the x-axis and left of
   the y-axis).
4. Editing font:
   Point the mouse to the label;
   Click the right button;
   Select proper color, size, style, and other font factors on the font edit board.
Tips:  WINGRIDDER is designed to plot primary graphs of the grid. You may add labels to indicate any objects on a graph. However, for a final graph, you should save the graph to an EPS file and then use other commercial graphic software to modify the graph.

2.3.8.9 Select a subset of a grid

Purpose: To select a subset of a grid.

How:
Method 1:
1. Click Plot → PickColumn on the menu bar.
2. Select Cells and Grids checkboxes and click display to show the map view of the grid.
3. Click the Pick Cells button. Caption of the button becomes the Picking Cells, which indicates that the WINGRIDDER now is in Picking Cell mode. Usually, you should click this same button several times (click ok or no on any pop-up windows that occur) until a pop-up window shows with warning information “You have selected 0 columns.” Click OK on this pop-up window to initialize the selection. Then click the Pick Cells button one more time to get into picking cell mode.

(a) You can follow these steps for three different cases:
(i) Select a profile: Select nodes one by one in an order that traces a profile;
(ii) Select boreholes: Select nodes that represent boreholes.
(iii) Select an area: Select nodes one by one in an order that traces a boundary of the area.

(b) Click the Picking Cells button to finish. The Picking Cells button changes to Pick Cells button, which means that you have completed the selection of columns. The Selected Cells check box on the top right corner will be activated.

(c) If two nodes selected in sequence are not connected, WINGRIDDER will warn you that the two columns are not connected and ask you if you want to automatically connect these two columns. Click Yes or No button according to your situation. If Yes button is clicked, the program will automatically connect the two columns by selecting the columns that form the shortest route between the two previously selected columns.

Method 2:
1. Click File menu bar and point to Save and then SelectedMesh; Click Ok button on the warning box;
2. Click No button on Question box, which then asks you if the selected columns are already in a file;
3. Follow Step 3, 4, 5, and 6 of Method 1 to select a sub-grid that you want.

Tips:
(a) Selecting an area is very similar to selecting a profile. Each consists of a chain of connected columns. The only difference is that the chain that encloses an area is a closed polygon (i.e., the first and the last columns are adjoined), while the chain of a profile is open (i.e., the first and the last columns must not be immediate neighbors). In other
words, WINGRIDDER decides whether you have selected an area or a profile by checking if two end columns of the chain are connected. If so, an area is selected, and WINGRIDDER will search all columns within the polygon defined by the chain and have them selected, too. Otherwise, only a profile is selected.

b) By selecting columns, all segments that are interfaces between the selected columns are automatically selected. Hence, this functionality actually facilitates a user to select a subgrid.

c) If all selected columns are isolated columns (no connections between them), no segment will be selected, and the selected subgrid is a set of multiple 1D grids.

d) If the selected columns exist, clicking Save SelectedMesh in the File menu will cause WINGRIDDER to show a saving file interface for you to save the selected sub mesh instead of the warning box of no columns selected.

2.3.8.10 Deselecting columns

Purpose: To discard the selection of a sub grid.

How:
1. Click Pick Cells button, the Pick Cells button becomes Picking Cells button;
2. Click Picking Cells button, WINGRIDDER will inform you that how many columns have been selected. Click Ok or No on the pop up window.
3. Repeat steps 1 and 2, until 0 column has been selected.

Tips:
(a) Each time you click the Pick Cells button, the previous selection will be cleared. Thus, clicking Picking Cells button without selecting any columns will result in an empty collection of the selected columns.
(b) Save the selection for next time before discarding it (see Section 2.3.9.2).

2.3.8.11 Show selected subgrid (map view)

Purpose: To visualize the selected subgrid with different colors.

How:
1. Check the check box of Selected Cells;
2. Click Display button. The selected subgrid will occur with a different color.

Tips: If the check box of Selected Cells is not activated, no column has been selected. You have to select the columns before you can show them.

2.3.8.12 Show a cross-sectional view of a selected profile

Purpose: To plot a cross section view of a 3-D grid.

How:
1. Select a profile (see Section 2.3.8.9);
2. Show it in a map view (see Section 2.3.8.11);
3. Select Cross section view from the “Select a plot plane” list;
4. Click Ok button on a message box showing how many columns you have selected;
5. Click Display button.

Tips: You can choose components to show by checking them. However, some components cannot be shown on a cross-sectional view. Fault cells are always yellow.

2.3.8.13 Printing graphs

Purpose: To get hard copies of a graph.

How:
1. Click Print button
2. Select a printer and then click print (you can modify settings of a printer if needed on the printer dialog box).

Tips: Clicking the Print button will send the current graph on the plot board to a printer. WINGRIDDER can use any printers that are available in the Windows operation environment of your PC. Note that if you select a printer other than the Windows’ default printer, the selected printer will become the Windows’ default printer after printing of the graph. Any modifications you made to the settings of the printer will be permanent. Of course, you can return to the Windows’ original default printer through Windows operation system (i.e., the printer setting dialog box).

2.3.8.14 Printing a graph to a disk file (EPS file)

Purpose: To get an electronic copy of a graph

How: Same as printing a graph on a printer, but select the File that is a virtual printer installed through the Windows’ setting printers functionality. Enter the filename for the graph in the filename box.

Tips: To use this functionality, you have to install a virtual printer that sends a graph to a graphic file. A format of Encapsulated PostScript (EPS) is proven to be successful. For details about how to install a virtual printer that sends a graph to a disk file, consult the manual of the Windows operation system.

2.3.9. Saving grid information (output files)

2.3.9.1 Saving 3D Mesh file for TOUGH2

Purpose: To save a mesh file that can be used as input by a TOUGH2 simulator.

How:
1. Select File→Save→3DMesh→ForTOUGH2 on the menu bar
2. Select a file from the mesh file list (if you want to overwrite an existing mesh file) or type a new file name into the file name box
3. Click Save (or Ok) button
4. Click Yes or No button on the pop-up window “Do you want to save index too?” according to your situation. If you select Yes, a list of the unique index for each cell and each connection will also be saved below keyword “+++” in the mesh file.

Tips: Use “mesh” as the extension of the mesh file.

2.3.9.2 Saving 3D Mesh file for checking

Purpose: To save cells of a grid into a disk file that can be used to check how well the three-dimensional grid represents the geological model of a site.

How:
1. Select File→Save→3DMesh→ForChecking on the menu bar
2. Select a file from the file list (if you want to overwrite an existing file) or type a new file name into the file name box;
3. Click Save (or Ok) button.

Tips: Use “mck” as the extension of the mesh file.

2.3.9.3 Saving 3D Mesh file for DualKGenerator

Purpose: To save a set of mesh files that can be used as input by a separate dual-permeability grid generator.

How:
1. Select File→Save→3DMesh→ForDualKGridGenerator on the menu bar;
2. Select a file from the file list (if you want to overwrite an existing file) or type a new file name into the file name box;
3. Click Save (or Ok) button;
4. Click Yes or No button on the pop-up window “Are the fault cells dual K too?” based on your situation.

Tips: (a) This version of WINGRIDER can generate dual-permeability (or 2K) grid as a special case of MINC grid. Therefore, this function is only needed when you want to use the old dual-K grid generator.
(b) Use “m2k” as the extension of the mesh file.

2.3.9.4 Saving 3D Mesh file for DCPT

Purpose: To save a mesh file that can be used as input by the dual continuum particle tracker--DCPT.

How:
1. Select File→Save→3DMesh→ForDCPT on the menu bar;
2. Select a file from the file list (if you want to overwrite an existing file) or type a new file name into the file name box;
3. Click Save (or Ok) button;
2.3.9.5 Saving 3D MINC Mesh file

**Purpose:** To save a (Multiple INteractive Continuum) MINC mesh file that can be used as input by TOUGH2 simulator.

**How:**
1. Select File→Save→3DMesh→MINC on the menu bar;
2. Select a MINC mesh file from the file list on a pop-up window;
3. Click Yes or No button on the pop-up window “Do you want to save Double Porosity type mesh (no global matrix connections)?” according to your needs;
4. Select an output file from the file list (if you want to overwrite an existing file) or type a new file name into the file name box;
5. Click Save (or Ok) button;
6. Click Yes or No button on the pop-up window “Do you want to save index too?” according to your situation. If you select Yes, a list of the unique index for each cell and each connection will also be saved below keyword “+++” in the mesh file.

**Tips:** Use “mesh” as the extension of the mesh file.

2.3.9.6 Save a subset of a 3-D mesh for TOUGH2

**Purpose:** To save a subgrid selected by selecting columns method into a mesh file that can be used as input by TOUGH2 simulator, and (optional) to save the configuration of the selected subgrid (columns and segments).

**How:**
1. Select File→Save→SelectedMesh→ForTOUGH2 on the menu bar;
2. If a pop-up window “Do you want to save MINC mesh?” occurs, Click Yes (save a MINC mesh) or No (save a regular mesh) based on your need; This pop-up window occurs only if the MINC mesh has been successfully created.
3. Select a file from the mesh file list (if you want to overwrite an existing mesh file) or type a new file name into the file name box;
4. Click Save (or Ok) button;
5. Click Yes or No button on the pop-up window “Do you want to save index too?” according to your situation. If you select Yes, a list of the unique index for each cell and each connection will also be saved below keyword “+++” in the mesh file.
6. Click the Yes button if you want to save the configuration of the selected subgrid, and choose a proper file or enter a proper file name. Otherwise, click the No button.

**Tips:** (a) If no sub grid is selected, clicking Save SelectedMesh will cause WINGRIDDER to warn you that no column is selected. You can either select a subgrid interactively or load the selection information from an existing previously saved disk file.
(b) Use “scc” as the extension of the file that contains configuration information of a selected subgrid. Always save the configuration file if you are not sure if it has been saved before so that you do not have to select the subgrid interactively again.

2.3.9.7 Save information of a subset of a 3-D mesh for quality checking

**Purpose:** To save a subgrid selected by selecting columns into a disk file that can be used to check how well the three-dimensional grid represents the geological model of a site, and (optional) to save the configuration of the selected subgrid (columns and segments).

**How:**
1. Select File→Save→SelectedMesh→ForChecking on the menu bar
2. Select a file from the mck file list (if you want to overwrite an existing mck file) or type a new file name into the file name box
3. Click Save (or Ok) button
4. Click the Yes button if you want to save the configuration of the selected subgrid, and choose a proper file or enter a proper file name. Otherwise, click the No button.

**Tips:**
(a) If no subgrid is selected, clicking Save SelectedMesh will cause WINGRIDDER to warn you that no column is selected. You can either select a subgrid interactively or load the selection information from an existing previously saved disk file.
(b) Use “scc” as the extension of the file that contains configuration information of a selected subgrid. Always save the configuration file if you are not sure if it has been saved before so that you do not have to select the subgrid interactively again.

2.3.9.8 Save selected mesh for dual-K grid generator

**Purpose:** To save a subgrid selected by selecting columns into a disk file that can be used by a separated dual-K grid generator.

**How:**
1. Select File→Save→SelectedMesh→For2KGenerator on the menu bar
2. Select a file from the m2k file list (if you want to overwrite an existing m2k file) or type a new file name into the file name box
3. Click Save (or Ok) button;
4. Click Yes or No button on the pop-up window “Are the fault cells dual K too?” based on your situation.

**Tips:**
(a) If no subgrid is selected, clicking Save SelectedMesh will cause WINGRIDDER to warn you that no column is selected. You can either select a subgrid interactively or load the selection information from an existing previously saved disk file.
(b) This version of WINGRIDDER can generate dual-permeability (or 2K) grid as a special case of MINC grid. Therefore, this function is only needed when you want to use the old dual-K grid generator.
2.3.9.9  Save a list of lateral connections through a selected profile

**Purpose:** To save a list of lateral connections through a user-selected profile.

**How:**
1. Select File→Save→SelectedMesh→ConsofLateralCut on the menu bar;
2. Select a file from the con file list (if you want to overwrite an existing con file) or type a new file name into the file name box
3. Click Save (or Ok) button
4. WINGRIDDER will inform you if the selected lateral connections have been successfully saved or not. Click OK on the pop-up window.

**Tips:** (a) If no sub grid is selected, clicking Save SelectedMesh will cause WINGRIDDER to warn you that no column is selected. You can either select a subgrid interactively or load the selection information from an existing previously saved disk file.
(b) Use “con” as file extension.

2.3.9.10  Save a list of selected columns

**Purpose:** To save a list of user-selected columns (i.e., the column name and its internal ID).

**How:**
1. Select File→Save→SelectedMesh→SelectedColumnNames on the menu bar
2. Select a file from the lst file list (if you want to overwrite an existing lst file) or type a new file name into the file name box
3. Click Save (or Ok) button
4. WINGRIDDER will inform you if the selected columns have been successfully saved or not. Click OK on the pop-up window.

**Tips:** (a) If no sub grid is selected, clicking Save SelectedMesh will cause WINGRIDDER to warn you that no column is selected. You can either select a subgrid interactively or load the selection information from an existing previously saved disk file.
(b) Use “lst” as the file extension.

2.3.9.11  Saving a mesh file of Boreholes for checking

**Purpose:** To save a checking file of all cells in the borehole columns used to compare with the geologic data of those boreholes.

**How:**
1. Select File→Save→Mesh of Boreholes→ForCheck on the menu bar
2. Select a file from the mck file list (if you want to overwrite an existing mck file) or type a new file name into the file name box
3. Click Save (or Ok) button;
Tips: A text file called “Borehole_Column.txt” will be saved as a byproduct, which contains a list of the LBNL names of the columns and the corresponding borehole names. A column is referred as a borehole column when its “kind” property contains the keyword “Bore”.

2.3.9.12 Saving a mesh file of Boreholes for TOUGH2

Purpose: To save a mesh file of the borehole columns that can be used by TOUGH2 simulator.

How:
1. Select File→Save→Mesh of Boreholes→ForTOUGH2 on the menu bar
2. Select a file from the mesh file list (if you want to overwrite an existing mesh file) or type a new file name into the file name box
3. Click Save (or Ok) button;

Tips: A text file called “Borehole_Column.txt” will be saved as a byproduct, which contains a list of the LBNL names of the columns and the corresponding borehole names. A column is referred as a borehole column when its “kind” property contains the keyword “Bore”.

2.3.9.13 Saving a List of Fault columns

Purpose: To save a list of LBNL names of the fault columns and the corresponding fault names.

How:
1. Click File→Save→List of Fault Columns on the menu bar
2. Select a file from the file list (if you want to overwrite an existing listing file) or type a new file name (extension “lst”) into the file name box
3. Click Ok button.

Tips: WINGRIDDER considers all columns whose “kind” property contains a keyword “Fault” as fault columns.

2.3.9.14 Saving a List of borehole columns

Purpose: To save a list of LBNL names for the borehole columns and the corresponding borehole names.

How:
1. Click File→Save→List of Borehole Columns on the menu bar
2. Select a file from the file list (if you want to overwrite an existing listing file) or type a new file name (extension “lst”) into the file name box
3. Click Ok button
4. If borehole data do not exist, WINGRIDDER will warn you and let you explore your hard disk to load a proper file of borehole data.

Tips: In contrast to the “Borehole_Column.txt", WINGRIDDER will in this case find the nearest column for each borehole regardless of the column’s “kind” property and save the list to the listing file.
2.3.9.15 Saving a List of the columns west of a fault

**Purpose:** To save a list of column names west of a user-selected fault. The program actually builds a polygon that consists of the trace of the selected fault and the two left corners of the domain (in counterclockwise order) and then saves the names of all columns in this polygon.

**How:**
1. Click File → Save → List of columns west of a fault
2. Select the fault file you want from the fault list (input file)
3. Click Ok button
4. Select the file (output file) from the file list (if you want to overwrite an existing file) or type a new file name (extension “lst”) into the file name box
5. Click Ok button.

**Tips:** The fault file must exist in the disk.

2.3.9.16 Saving a List of repository cells by Region

**Purpose:** To list any cell whose representative node is located inside one of the repository regions and is closest to the elevation of the repository at that location in a disk file.

**How:**
1. Click File → Save → Repository Cell → By Region
2. Click the file from the file list (if you want to overwrite an existing file) or type a new file name (extension “lst”) into the file name box
3. Click Ok button.

**Tips:** You must have repository loaded before using this function. A cell is considered to be inside of a repository if its node is inside the repository even though the majority of its volume is outside.

2.3.9.17 Saving a List of repository cells by repository drifts

**Purpose:** To list any cell that intersects with repository drifts.

**How:**
1. Click File → Save → Repository Cell → By Drifts
2. Click the file from the file list (if you want to overwrite an existing file) or type a new file name (extension “lst”) into the file name box
3. Click Ok button.

**Tips:** You must have repository file (type 2: containing individual drifts) loaded before using this function. A cell is considered as a repository cell if its volume is intersect with any repository drift(s) even though its representative node is outside of the repository.
2.3.9.18  Saving the list of cells of a particular layer (including repository horizon)

**Purpose:** To save the information of all cells that belong to a user-specified layer or repository horizon.

**How:**
1. Click File→Save→Pick Cells by layer
2. Select a layer from the list provided in a pop-up window and click OK button
3. Click the file from the file list (if you want to overwrite an existing file) or type a new file name (extension “mck”) into the file name box
4. Click Ok button.

**Tips:** The number of cells in this file always equals the number of columns because each column will contribute a cell, no matter whether the specified layer is missing or not at the location of a particular column.

2.3.9.19  Saving a Segment file in a format compatible with Amesh

**Purpose:** To save segments (in map view) in a format compatible with Amesh that can be used by previous postprocessing programs for plot purpose.

**How:**
1. Click File→Save→Segments as amesh
2. Select the file from the list (if you want to overwrite an existing file) or type a new file name (extension “grd”) into the file name box
3. Click Ok button.

**Tips:** A better way to output a 2-D grid graph is to print the graph to a file.

2.3.9.20  Saving mesh files for Dual-permeability grid Generator

**Purpose:** To save mesh files readable by the dual-permeability grid generator.

**How:**
Click File→Save→Mesh for DualK Generator.
The WINGRIDDER will ask you to enter the filename of the “m2k” file.

**Tips:** This function should be used only if you want to use some separated dual permeability grid generator. If you want use the dual-permeability grid generator in the WINGRIDDER, you do not have to use this function first. Instead, you can directly use the MINC generator with one matrix cell.

2.3.9.21  Saving mesh files for DCPT

**Purpose:** To save mesh files readable by the DCPT (Dual Continua Particle Tracker) V1.0 or V2.0.
How: 
Click File→Save→Grid for Particle Tracking. The WINGRIDDER will ask you to enter a filename.

Tips: This function is designed for DCPT users only.

2.3.9.22 Saving Ids of those source cells for DCPT

Purpose: To save source cell Ids for DCPT. The source cells are the repository cells as defined in Section 2.3.9.16.

How: Click File→Save→Repository CellID for DCPT. The WINGRIDDER will ask you to enter a filename.

Tips: This function is designed for DCPT users only.

2.3.9.23 Saving the bottom elevation of a user-selected layer in a binary file

Purpose: To save the bottom elevation of a user-selected layer in a binary file.

How:
1. Click File→Save→BinaryFileofLayerBottom
2. Select a layer from the list provided in a pop-up window and click OK button
3. Click the file from the file list (if you want to overwrite an existing file) or type a new file name (extension “bot”) into the file name box
4. Click Ok button.

Tips: If you want to create a binary file from an ASCII file, use Tools→ASCIItoBinary.

2.3.9.24 Saving list of cells for each drift

Purpose: To save a list of any cell that intersects with a drift. Each drift will have an individual file.

How: Click File→Save→List of cells of a drift.

Tips: A 3D grid must be ready and the drift files must have been loaded before use this function. The saved file will have a name like “driftName”+ “.lst”.

2.3.9.25 Saving a list of boundary cells (top boundary of a polygon)

Purpose: To save a list of the top boundary cells of a 3D grid within a particular polygon.

How:
1. Click File→Save→List of boundary cells→TopBoundary
2. Select a polygon from the list provided in a pop-up window and click OK button
Tips: The polygons listed in the pop-up window are names of objects that have been loaded by Load→Bound. The saved file will have a filename like “polygonName” + “.Bcell” and the corresponding face file like “polygonName” + “.BFace”. The face file contains the list of the interfaces (connections) that connected to the boundary cells.

2.3.9.26 Saving a list of boundary cells (bottom boundary of a polygon)

Purpose: To save a list of the bottom boundary cells of a 3D grid within a particular polygon.

How:
1. Click File→Save→List of boundary cells→Bottom
2. Boundary Select a polygon from the list provided in a pop-up window and click OK button

Tips: The polygons listed in the pop-up window are names of objects that have been loaded by Load→Bound. The saved file will have a filename like “polygonName” + “_b.Bcell” and the corresponding face file like “polygonName” + “_b.BFace”. The face file contains the list of the interfaces (connections) that connected to the boundary cells.

2.3.9.27 Saving a list of internal boundary cells

Purpose: To save a list of the internal boundary cells within a particular polygon.

How:
1. Click File→Save→List of boundary cells→InternalBoundary→all
2. Select a polygon from the list provided in a pop-up window and click OK button

Tips: The internal boundary cells exist when an object such as a drift has been dug out from a 3D grid. The polygons listed in the pop-up window are names of objects that have been loaded by Load→Bound. The saved file will have a filename like “polygonName” + “_ia.Bcell” and the corresponding face file like “polygonName” + “_ia.BFace”. The face file contains the list of the interfaces (connections) that connected to the boundary cells.

2.3.9.28 Saving a list of internal boundary cells (top only)

Purpose: To save a list of the internal boundary cells within a particular polygon on the top of the internal hole.

How:
1. Click File→Save→List of boundary cells→InternalBoundary→Top
2. Select a polygon from the list provided in a pop-up window and click OK button

Tips: The internal boundary cells exist when an object such as a drift has been dug out from a 3D grid. The polygons listed in the pop-up window are names of objects that have been loaded by Load→Bound. The saved file will have a filename like “polygonName” +
"_it.Bcell" and the corresponding face file like "polygonName" + "_it.BFace". The face file contains the list of the interfaces (connections) that connected to the boundary cells.

2.3.9.29 Saving a list of internal boundary cells (bottom only)

**Purpose:** To save a list of the internal boundary cells within a particular polygon on the bottom of the internal hole.

**How:**
1. Click File → Save → List of boundary cells → InternalBoundary → Bottom
2. Select a polygon from the list provided in a pop-up window and click OK button

**Tips:** The internal boundary cells exist when an object such as a drift has been dug out from a 3D grid. The polygons listed in the pop-up window are names of objects that have been loaded by Load → Bound. The saved file will have a filename like "polygonName" + "_ib.Bcell" and the corresponding face file like "polygonName" + "_ib.BFace". The face file contains the list of the interfaces (connections) that connected to the boundary cells.

2.3.9.30 Saving a list of internal boundary cells (side only)

**Purpose:** To save a list of the internal boundary cells within a particular polygon on the side of the internal hole.

**How:**
1. Click File → Save → List of boundary cells → InternalBoundary → Side
2. Select a polygon from the list provided in a pop-up window and click OK button

**Tips:** The internal boundary cells exist when an object such as a drift has been dug out from a 3D grid. The polygons listed in the pop-up window are names of objects that have been loaded by Load → Bound. The saved file will have a filename like "polygonName" + "_is.Bcell" and the corresponding face file like "polygonName" + "_is.BFace". The face file contains the list of the interfaces (connections) that connected to the boundary cells.

2.3.10. Tools

2.3.10.1 Text Editor

**Purpose:** To use a text editor to view, edit, and print a text file that may be an input, output, or intermediate file.

**How:** Click Tools → TextEditor → Notepad.
A Notepad or WinWord will appear on the screen.

**Tips:** WINGRIDDER actually calls Windows’ Notepad or WinWord if the size of the file is too large for Notepad. Because the text editor is a third-party component, WINGRIDDER will not track its status after calling it. It is your responsibility to close it after finishing your job.
2.3.10.2 Text column mixer

**Purpose:** To make a mixed copy of two text files. The new file contains exactly the same numbers of text columns of the target file but some user-selected columns have been replaced with the texts from the same location in the source file.

**How:**
1. Click Tools→TextEditor→ReplaceColumns
2. Select the target file (the file need to be modified) from the file list on the pop-up window and then click Open
3. Select the source file (the file provides the new texts) from the file list on the pop-up window and then click Open
4. A pop-up window will occur. It shows the first 10 lines of texts in the target file below the column marks (i.e., “----+----+”).
5. The first 10 lines of text within the selected column range from the source file appear under the title “new text”. You can change them by modifying the values in “Starting Column” box or “Ending Column” box on the left-top conner.
6. Click OK button to finish the job. A new file will be created and saved with a filename containing the target filename and the keyword “_new”.

**Tips:** This function is designed to provide a column wise text replacement capability which most text editors do not provide.

2.3.10.3 Quality checking of 3-D cells

**Purpose:** To check vertical connections of 3-D cells and lateral connections of repository cells. WINGRIDDER will warn you if ether of following situations exists:
(1) Any cell has no cell below it except the bottom boundary cell in any column;
(2) Any cell has no bottom face (connection) except the bottom boundary cell in any column;
(3) Any repository cell only has one or fewer lateral connections.

**How:** Click Tools→Q-Checking→3DCells on the menu bar.

**Tips:** Do not use this function before the entire grid has been completely built.

2.3.10.4 Quality checking of 3-D connections

**Purpose:** To check if any duplicated lateral connections exist.

**How:** Click Tools→Q-Checking→3DCons on the menu bar.

**Tips:** Do not use this function before the entire grid has been completely built.
2.3.10.5  Quality checking of overlapped columns

**Purpose:** To check if any duplicated columns exist.

**How:** Click Tools→Q-Checking→Overlap Columns on the menu bar

**Tips:** This is a slow process. Use it only when necessary.

2.3.10.6  Amend open polygons

**Purpose:** To check if the segments of any column form a closed polygon. If not, the gap between the end points of two related segments will be removed.

**How:** Click Tools→Q-Checking→Amend Open Polygon on the menu bar. If open polygon found, click Yes on the pop-up window until the pop-up window with message “Congratulation! No open polygon found!” occurs.

**Tips:** This is a slow process. Use it only when necessary (e.g., when the grid will be used for a random walking particle tracking program such as DCPT).

2.3.10.7  Remove nodes almost on the domain boundary

**Purpose:** To remove any node that is located almost on the domain boundary.

**How:** Click Tools→Q-Checking→Remove Nodes TooCloseToBoundary on the menu bar

2.3.10.8  Find steep lateral connections

**Purpose:** To find any lateral connection whose dipping degree is larger than the user-specified. The dipping degree is defined as the degree between the connection and the horizon.

**How:**
1. Click Tools→Q-Checking→SteepLateralConnections on the menu bar
2. Enter a degree (0-90) into the text box on the pop-up window
3. Click OK on the pop-up message box which tells you how many qualified lateral connections found. The program will save a list of the qualified connections in a text file “SteepCons.mck”.

2.3.10.9  Find level vertical connections

**Purpose:** To find any vertical connection whose dipping degree is smaller than the user-specified. The dipping degree is defined as the degree between the connection and the horizon.

**How:**
1. Click Tools→Q-Checking→LevelVerticalConnections on the menu bar;
2. Enter a degree (0-90) into the text box on the pop-up window;
3. Click OK on the pop-up message box which tells you how many qualified lateral connections found. The program will save a list of the qualified connections in a text file “LevelCons.mck”.

2.3.10 Check consistency between vertical connections and the cell elevations

**Purpose:** To find any cells whose elevations are not consistent with the length of the related vertical connection. The elevation is considered to be inconsistent if $|C1.z - D - C2.z| > 0.1$ , where $C1.z$ and $C2.z$ are the elevations of two neighboring cells, respectively. D is the length of the vertical connection that connects the two cells, C1 and C2.

**How:**
1. Click Tools→Q-Checking→CheckCellElevation on the menu bar;
2. Click OK on the pop-up window which tells you how many cells found to be inconsistent with their vertical connections. The program will save a list of the found cells in a text file “WrongCellZ.txt”.

2.3.11 Remove redundant data points from fault files

**Purpose:** To remove any data point that is collinear with its two neighbors in a fault file.

**How:**
1. Click Tools→RemoveRedundantPoint→Faults on the menu bar
2. Select fault files from the pop-up window and click Open button.

**Tips:** The original fault files must reside in directory other than the current working directory. You can select multiple files at once to complete the simplification job for all selected files.

2.3.12 Convert an ASCII file into a binary file

**Purpose:** To convert an ASCII data file into a binary data file.

**How:**
1. Click Tools→ASCIItoBinary on the menu bar
2. Select files from the file list on the pop-up window and click OK

**Tips:** The new files will have the same name as the original files if the original files do not reside in the current working directory. Otherwise, keyword “_Bi” will be inserted into the old filename to create a new filename. The list of binary files will be saved in “BFileList.dat” in the working directory.

2.3.13 Convert fracture property file

**Purpose:** To convert a fracture property file from old format into new format.
How:
1. Click Tools→ResaveFractureProperty on the menu bar;
2. Select the fracture property file from the file list on the pop-up window and click OK

Tips: The new files will have a similar name as the old file with an inserted keyword “_new”.

2.3.10.14 Search column

Purpose: To find a particular column and mark it on the map view with blue node and green segments.

How:
1. Click Tools→Search on the menu bar;
2. Enter the ID (or Name) of the column that you want to find in the pop-up text box and press Enter key (or click OK).

Tips: If the column ID or name is a valid one, the program will show it by a blue node and green segments that compose a polygon (normal column has a red node with blue polygon).

2.3.10.15 Find rock composition of repository

Purpose: To calculate the rock composition within the repository area and save the results (i.e., the rock name, the area it occupied, and the its percentage to the total area of the repository) into a disk file.

How:
1. Click Tools→CalRockCompositionOfRepository on the menu bar;
2. Enter a proper filename into the file box on the pop-up window and click OK

Tips: The rules for determining whether or not a cell is a repository cell are the same as those used in Save repository cells by region (Section 2.3.9.16).

2.3.10.16 Preprocessing: Grouping Pulse

Purpose: To reduce the data points of a time series of pulses by lumping them based on given condition.

How:
1. Click Tools→PreProcessing→GroupingPulses on the menu bar;
2. Select a time series file from the file list on the pop-up window and click Ok;
3. Enter a prefer time step you want to use;
4. Check the mass balance error and click OK on the pop-up window.

Tips: (a) If the entered prefer time step is positive, the pulses will be lumped around the given prefer time step. The lumped pulses will always separated by zeros.
(b) If the entered prefer time step is negative, the pulses will be lumped exactly at the
given prefer time step no matter if it is zero or not.
(c) The time series of pulses in the input file must start with a zero followed by a nonzero
value and so on. The lumped pulses will be in the same pattern and saved in a new file
(the new filename is modified from the original filename by inserting "_new").

2.3.10.17 Preprocessing: Assign boundary conditions

Purpose: To assign boundary conditions to the gridded model domain and save the BC to proper
TOUGH2 input files (workable for a special version of EOS9 only).

How:
1. Click Tools→PreProcessing→AssignBoundaryCondition on the menu bar
2. The “Assign Boundary Conditions” window will pop-up. Select a region in the pull-down
menu of “Select an Object” on the right–up corner of the window. The selected region
and the nodes within the region will be highlighted
3. The default BC type is first type (e.g., pressure, saturation, etc., only applicable for EOS9
for now) as shown in the First Type button on the right side. If you want to assign flow
type (e.g., prescribed flow rate), click the First Type button. It will become the Flow
button to indicate that the BC type is flow type for the selected nodes. (Click this button
again would switch back to First Type)
4. Enter a value in the BC Value box
5. Click Top, Bottom, or Internal button to assign the boundary conditions for the top,
bottom, or internal boundary, respectively
6. Repeat steps 2-5 to assign boundary for different regions (by selecting a proper region).
7. Click Save BC button to save the assigned boundary conditions in proper TOUGH2 input
files.
8. Enter a proper project name (i.e., the common filename) and click OK on the pop-up
window.
9. The program will then ask you to confirm if the entered project name is right. Click Yes
to confirm.
10. Click Yes or No button to the question: “Do you want to save MESH file too?” according
to your situation.
11. If click Yes on Step 10, a pop-up window would appear to ask you if you want to save
index too. Click Yes or No as you need.

Tips: (a) The files generated by using this function might not work for regular versions of
TOUGH2.
(b) First type boundary conditions are implemented in INCON file.
(c) Flow type boundary conditions are implemented in GENER file.
(d) The BC value entered on Step 4 could be, besides a numeric value, a string from
following three options:
   (i) Variable
   (ii) Seepage
   (iii) One of Drain, Free drain, drainage, or free drainage
If “Variable” is entered, the program will ask you to select a BCO file. The data in a BCO file starts with the number of data pairs in the first row and each row followed contains the start time and the corresponding BC value. If “Seepage” is entered, the seepage boundary condition is implemented in the TOUGH2 mesh file that the orientation of the related connection is “-5” (Cell1 is the boundary) or “-6” (Cell2 is the boundary). If “Drain” (or other similar terms) is entered, a special rock “DRAIN” will be assigned to the related cells in the TOUGH2 mesh file. In both case ii and iii, the modified mesh file has to be saved (i.e., click Yes on Step 10).

2.3.10.18 Preprocessing: Insert line sources

**Purpose:** To create a GEN file (a COM1 source term file) to represent line sources in the domain.

**How:**
1. Click Tools→PreProcessing→InsertLineSource on the menu bar;
2. Follow the on-screen instructions to load one or more drift files.
3. If MINC mesh has been created, follow the on-screen instructions to select the MINC grid file.

**Tips:**
(a) The GEN files will have filenames following the corresponding drift names ended with “.GEN”.
(b) The injection rate in each cell is proportional to the length of the line source in that particular cell. The total injection rate of a drift is specified in the drift file as a negative diameter (i.e., total rate = |diameter|).

2.3.10.19 Preprocessing: Combine source files

**Purpose:** To combine multiple source files into a single file that all source terms for the same cell will be lumped together.

**How:**
1. Click Tools→PreProcessing→CombineSourceFiles on the menu bar;
2. Select source files from the source file list on the pop-up window and click Ok.

**Tips:** This function is to used to combine the multiple source files created using steps described in Section 2.3.10.18.

2.3.10.20 Post processing: Match data to grid

**Purpose:** To match status variables of cells to the corresponding cells in a cell list file. The results will be saved in an output file that each row contains the location (e.g., s, x, y, z) and the variables (e.g., saturation, concentration, and water pressure) at that location.
How:
1. Click Tools→PostProcessing→MatchDatatoGrid on the menu bar;
2. Select the data file from the file list on the pop-up window and click Ok;
3. Select the cell list file from the file list on the pop-up window and click OK;
4. Enter an output file name in the file box on the pop-up window and click Save;

Tips:  (a) The function is usually used to match the data with its location for a profile extracted from a large 3-D mesh.
     (b) The data file must be a Flow9 file (the flow field file created by EOS9 module of TOUGH2).

2.3.10.21 Post processing: Convert flow field file from 2K to MINC

Purpose: To create an equivalent flow field file for MINC mesh based on a flow field file for 2K mesh.

How:
1. Click Tools→PostProcessing→MINC→Flow:2KtoMINC on the menu bar;
2. Select a proper MINC database file (*.mdb) from the file list on the pop-up window and click Ok;
3. Select a proper Flow9 file for 2K mesh from the file list on the pop-up window as input file and click Ok;
4. Enter a proper Flow9 filename calculated based on a MINC mesh into the filename box on the pop-up window as output file and click Save;

Tips: The output file is a Flow9 file for the MINC mesh but is equivalent to a 2K mesh (i.e.,
global flux is the same for the sub-cells in the MINC mesh as that of the matrix cell in the
2K mesh.)

2.3.10.22 Post processing: Convert flow field file from MINC to 2K

Purpose: To create an equivalent flow field file for 2K mesh based on a flow field file for MINC mesh.

How:
1. Click Tools→PostProcessing→MINC→Flow:MINCto2k on the menu bar;
2. Select a proper Flow9 file calculated based on a MINC from the file list on the pop-up window as input file and click Ok;
3. Enter a proper Flow9 filename for 2K into the filename box on the pop-up window as output file and click Save;

Tips: The output file is a Flow9 file for 2K mesh in which the global matrix flux is an area-weighted average of the matrix fluxes in the corresponding sub-matrix-cells in the MINC mesh.
2.3.10.23 Post processing: Set initial condition for MINC

**Purpose:** To set and save initial conditions to a disk file.

**How:**
1. Click Tools→PostProcessing→MINC→SetInitialCondition on the menu bar;
2. Select a proper MINC mdb file from the file list on the pop-up window as input file and click Ok;
3. Enter a proper filename for the initial condition file into the filename box on the pop-up window as output file and click Save;
4. Enter a proper default value into the text box on the pop-up window and click OK.

**Tips:** If the concentration data for cells have been imported before, the concentration for each cell will be save in the initial condition file. Otherwise, the default file is used.

2.3.10.24 Post processing: Extract residual values from ITOUGH2 output file

**Purpose:** To extract the observed, the calculated, and the residual data from ITOUGH2 output file(s) and save them to text file(s).

**How:**
1. Click Tools→PostProcessing→ITOUGH2→Getresidual on the menu bar;
2. Select one or more ITOUGH2 output files from the file list on the pop-up window as input files and click Ok;

**Tips:** The output file will have a similar name as the input file (ITOUGH2 output file) with a new file extension “.dat”. If multiple ITOUGH2 output files are selected in Step 2, multiple output files will be created accordingly.

2.3.10.25 Post processing: Calculate the total lateral flow within each geological layer at a column

**Purpose:** To calculate the total lateral flow within each geological layer at a column based on the lateral flow data per connection and save the following data for each layer: Name of the layer, flow rate, bottom elevation, top elevation, number of grid cells, mean thickness, minimum thickness, maximum thickness.

**How:**
1. Click Tools→PostProcessing→TOUGH2→SumLateralFlowperLayer→For a Column on the menu bar;
2. Select a proper file of the lateral flow data per connection from the file list on the pop-up window as input and click OK;
3. Enter a proper filename for the output file into the filename box on the pop-up window and click Ok;
4. A pop-up window with two column names will appear. You must enter one of them into the text box as the selected column. Otherwise, the program will ask you to reenter the right column name.
Tips:  (a) The original lateral flow data in the input file are usually extracted from a Flow9 file based on the selected lateral connections (see Section 2.3.9.9 for saving a set of the selected lateral connections and see Section 2.3.8.9 for selecting one or more columns). Each row of lateral flow data consists of a connection name (Cell1 + Cell2), flow rate, and flux in the format as “1X,C8,1X,C8,2X, 2E20.13”. The connection name is a combination of two neighboring cells while the cell name must be an 8-character name.
(b) Before using this function, you must open a proper grid project (i.e., the flow file was created based on the grid that has been loaded).
(c) Naming convention of cells must be that the last three character of a cell name is the name of the column to which it belongs.

2.3.10.26 Post processing: Calculate the total lateral flow within each geological layer along a profile

Purpose: To calculate the total lateral flow within each geological layer along a profile (a cut through a 3D grid) based on the lateral flow data per connection and save the following data for each layer: Name of the layer, flow rate, bottom elevation, top elevation, number of grid cells, mean thickness, minimum thickness, maximum thickness.

How:
1. Click Tools→PostProcessing→TOUGH2→SumLateralFlowperLayer→For a profile (cut) on the menu bar
2. Select a proper file of the lateral flow data per connection from the file list on the pop-up window as input and click Ok
3. Select a proper file of the list of column names and click Ok
4. Enter a proper filename for the output file into the filename box on the pop-up window and click Ok;

Tips: (a) The original lateral flow data in the input file are usually extracted from a Flow9 file based on the selected lateral connections (see Section 2.3.9.9 for saving a set of the selected lateral connections and see Section 2.3.8.9 for selecting one or more columns). Each row of lateral flow data consists of a connection name (Cell1 + Cell2), flow rate, and flux in the format as “1X,C8,1X,C8,2X, 2E20.13”. The connection name is a combination of two neighboring cells while the cell name must be an 8-character name.
(b) Each row of the data in the column list file consists of two items: the column name and the column ID separated by one or more spaces. The column names should be consistent with the names embedded in the cell names of the flow data file while the column ID should be consistent with the column ID used in WINGRIDDER. This file can be created following steps in Section 2.3.9.10.
(c) Before using this function, you must open a proper grid project (i.e., the flow file was created based on the grid that has been loaded).
(d) Naming convention of cells must be that the last three character of a cell name is the name of the column to which it belongs.
2.3.10.27 Post processing: Extract breakthrough data from a T2R3D output file

**Purpose:** To extract the total mass flowed out from the bottom of the domain and the associated time. The resulted time series, saved to a disk file, will consist of the time and the ratio of the mass flow out at that time over the total mass injected in time zero.

**How:**
1. Click Tools→PostProcessing→T2R3D→ExtractBT on the menu bar
2. Select a proper T2R3D output file from the file list on the pop-up window as input and click OK
3. Enter a proper filename for the BT file into the filename box on the pop-up window and click Ok.

**Tips:** If all mass is injected at time zero, the saved data can be considered as a breakthrough curve. Otherwise, the user should be careful in explaining the saved data.

2.3.11 Find license information

**Purpose:** To find license information and software version.

**How:**
1. Click Help→About GridGnerator . . .
2. Click License.

2.4 REQUIRED TRAINING

The users must be trained to be familiar with (1) numerical modeling of fluid flow and transport in dual-continua media, particularly the integral finite difference method or the control volume method, (2) geological structures and their descriptions, (3) numerical grid generation, and (4) this document.

2.5 INPUT SPECIFICATION

The software is to take the user-developed data (as electronic files) from the geological model such as the Geological Framework Model, GFM3.1, of Yucca Mountain and the user-generated data (as electronic files or as manual input interactively) of the grid and generate a grid file suitable for use in TOUGH2. WINGRIDDER V3.0 will not accept any printed-inputs.

The software will accept the following (electronic) input files:

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Optional/Required</th>
</tr>
</thead>
<tbody>
<tr>
<td>Domain boundary</td>
<td>Generated</td>
<td>Required</td>
</tr>
<tr>
<td>Repository</td>
<td>Developed</td>
<td>Optional</td>
</tr>
<tr>
<td>Geological layers</td>
<td>Developed</td>
<td>Required</td>
</tr>
<tr>
<td>Rock properties</td>
<td>Developed</td>
<td>Required</td>
</tr>
</tbody>
</table>
Faults | Developed | Optional
---|---|---
Drifts | Developed | Optional
Boreholes | Developed | Optional
Fractures | Developed | Optional

The software will accept the following manual inputs:

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Optional/Required</th>
<th>Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Node spacing</td>
<td>Generated</td>
<td>Required</td>
<td>Numerical (real)</td>
</tr>
<tr>
<td>Node orientation</td>
<td>Generated</td>
<td>Required for assign domain nodes</td>
<td></td>
</tr>
<tr>
<td>Y to X ratio</td>
<td>Generated</td>
<td>Required for assign domain nodes and repository nodes</td>
<td></td>
</tr>
<tr>
<td>Minimum ratio</td>
<td>Generated</td>
<td>Required</td>
<td></td>
</tr>
<tr>
<td>Critical elevation</td>
<td>Developed</td>
<td>Optional</td>
<td></td>
</tr>
<tr>
<td>Minimum and maximum thicknesses for grid cells</td>
<td>Developed</td>
<td>Required</td>
<td></td>
</tr>
<tr>
<td>Fault node parameters</td>
<td>Developed</td>
<td>Required for assigning Fault nodes</td>
<td></td>
</tr>
<tr>
<td>Filename</td>
<td>Generated</td>
<td>Required for creating new file</td>
<td>String</td>
</tr>
</tbody>
</table>

The electronic input files (Note that the file formats are given in Appendix A):

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Source</th>
</tr>
</thead>
<tbody>
<tr>
<td>Domain boundary</td>
<td>Define the aerial extent (as a polygon), the top and the bottom elevations of the modeling domain in x-y-z coordinates</td>
<td>Generated by the user</td>
</tr>
<tr>
<td>Repository</td>
<td>(single region) Define the aerial extent (as a polygon) and the parameters of the elevation equation of the repository (multiple region) Define the aerial extent (as a polygon) of each sub-region and coordinates of all individual drifts</td>
<td>Developed by the user from engineering document (data)</td>
</tr>
<tr>
<td>Geological layers</td>
<td>Define the geometry relationships between hydraulic units and the thickness (or elevation) of these units</td>
<td>Developed by the user from the Geological model</td>
</tr>
<tr>
<td>Rock Properties</td>
<td>Define one-to-one relationship between a rock name and a hydraulic unit for spatially uniform layer; Otherwise, define polygons that define rock zones within each unit if there are any multiple zones of rock in the layer</td>
<td></td>
</tr>
<tr>
<td>Faults</td>
<td>Define the 3-D layout of faults with x-y-z coordinates and the width of fault zones</td>
<td></td>
</tr>
<tr>
<td>Fractures</td>
<td>Define the fracture properties of each hydraulic unit</td>
<td></td>
</tr>
<tr>
<td>Boreholes</td>
<td>Define x-y coordinates of each boreholes</td>
<td></td>
</tr>
<tr>
<td>Drifts</td>
<td>Define the 3-D layout of drifts with x-y-z coordinates and the size of drifts</td>
<td></td>
</tr>
</tbody>
</table>

The manual inputs:
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Source</th>
</tr>
</thead>
<tbody>
<tr>
<td>Node spacing</td>
<td>The average distance between two neighboring nodes</td>
<td>Developed by the user from geological and engineering data</td>
</tr>
<tr>
<td>Node orientation</td>
<td>The angle to the positive x-axis, with which the nodes will be aligned (only used for domain nodes)</td>
<td></td>
</tr>
<tr>
<td>Y to X ratio</td>
<td>The ratio of the node-spacing along y-direction over that along the x-direction (the user-specified node spacing)</td>
<td></td>
</tr>
<tr>
<td>Minimum ratio</td>
<td>The minimum ratio allowed in deciding if a segment should be deleted. The ratio is defined as the ratio of the square of the segment length over the area of the adjacent columns (the smaller one)</td>
<td></td>
</tr>
<tr>
<td>Critical elevation</td>
<td>Below this elevation, a secondary minimum thickness will be used when creating the cells</td>
<td></td>
</tr>
<tr>
<td>Minimum thickness</td>
<td>If the thickness of a hydraulic unit at the location of a particular column is smaller than this thickness, the hydraulic unit is considered being pinched-out there and no cell will be created for this unit. Any remaining thickness will be added to the cell above. WINGRIDDER Version 3.0 allows user to specify individual minimum thickness for each layer.</td>
<td></td>
</tr>
<tr>
<td>Maximum thickness</td>
<td>If the thickness of a hydraulic unit at the location of a particular column is larger than this thickness, the unit will be evenly split and multiple cells will be created for the unit. WINGRIDDER Version 3.0 allows user to specify individual maximum thickness for each layer.</td>
<td></td>
</tr>
</tbody>
</table>
| Fault node parameters | Three parameters (Mindis, Width, and AvgDis) for each fault.  
  Mindis: If the horizontal shift of the fault’s trajectories at two levels is less than Mindis, the fault will be represented as a vertical fault in the grid. Otherwise, it will be an inclined fault.  
  Width: the width of the fault cells.  
  AvgDis: the maximum distance between two adjacent fault nodes of the fault |                                                                         |
| Filename           | Any strings are valid as filenames in Windows environment                   | Generated by the user                                                  |

### 2.6 OUTPUT SPECIFICATION

The output grid will be in the form of mesh files used with TOUGH2 and other TOUGH family codes. The mesh files and file format can be found in the TOUGH2 document (Pruess et al, 1996).

### 2.7 DATA FILES

For a description of data files, see Section 2.5 above and Appendix A.
2.8  DEFAULTS

There are no defaults in this code.

2.9  ERRORS

No particular error handling methods are implemented in WINGRIDDER V3.0. The Windows operating system shall handle any anticipated run-time errors. The user shall follow the instructions from the operating system.

2.10  HARDWARE/SOFTWARE ENVIRONMENTS

This software is intended to be run on PCs with Windows XP. The hardware system needs to be, at a minimum, a Pentium II CPU with 128 MB RAM and 500 MB disk, and a CD Drive. The disk space requirement could be much higher than the minimum requirement if one wants to build a very large grid. There are no external software systems or database managers associated with this software other than the operating system.

2.11  SAMPLES

Four sample problems and related input and output files are described in Appendix B.
3. INSTALLATION AND VALIDATION

3.1 INSTALLATION AND INSTALLATION VERIFICATION

3.1.1 Pre-Installation Tasks
Remove WINGRIDDER V1.0 or V1.1 or V2.0 on the user’s PC using MS Windows’ Add/Remove Program functionality if any before install WINGRIDDER V3.0.

3.1.2 Actions Necessary to Complete the Installation Procedure
The program will need Windows XP on a PC with a CD drive to run.
Insert the CD into the CD drive.
Click Start→Run on the Windows and then click Browser button.
Select the \WG30\Setup.exe on the CD drive.
Follow the instructions on the screen in install the software.

3.1.3 Software and Data Transfer to the Target Platform
Unzip all the zipped files of test cases from the CD to the user installation directory on his/her hard drive

3.1.4 Tasks to be Performed Following the Software Transfer
Make sure all files transferred to the target platform (the examples) are not read-only. Change the attributes through the Windows operating system if needed.

3.1.5 Setting Initial Operating Conditions
See Section 3.1.4.

3.1.6 Installation Test Case
The test case to be used, which accurately confirms a correct installation and ready-for-use condition, is as follows (Be sure that you load and save the test case files from the CD under your directory “\Case1\”):

Step 1. Run WINGRIDDER V3.0
Load lateral boundary information: File→Load→Bound
Select file “Sample3D.bnd”. This file defines the lateral boundary of the domain.
From menu bar, select Design 2D
Under “Select an Object,” choose DomainBound; Specify an Average Distance (node spacing): 10 (distance in meters) and click Add Nodes. A number of windows pop up. Enter the following information:
“Rectangular mesh?”: Yes
“Please enter Angle to PositiveX”: enter 0
“Please enter the ratio of size:Y to X”: enter 1
Click “Save” and the file is saved as “Sample3D.in”
From the menu bar, select: Generate 2D
Select “Sample3D.in” and click “Open”

Step 2. Load the 2-D grid information: From the menu bar, select File→Load→Grid
Select file “Sample3D.grd” and click “Open”.
Click “OK” on the next window.
Step 3. Generate the 3-D grid
From the menu bar, select: Generate→3D→Full mesh
A window pops up and asks the user “Do you want to save the project automatically?”: select “Yes.”
The project is saved as: “Sample3D.prj”
Pop-up windows appear for which the following information is specified:
“No layers! You Should load layer data first!?”: click “OK”.
Select “LayerList” in the Open File window and click “Open”.
Select “LayerList.roc” in the Open File window and click “Open”.
If the pop-up window with a question of “Do boreholes have their own layering information?” occurs, click “No” button. Otherwise go below.
“Use long LBNL name (8 characters)?”: select “No”
“Please type in the MINIMUM thickness of a cell. A layer that has thickness smaller than this value will be ignored!”: enter 1 (meters).
“Please type in the MAXIMUM thickness of a cell. A layer that has thickness larger than this value will be subdivided!”: enter 10 (meters).
Click “Default” and then “OK” on the Edit Layer option window.
“Do you want to have a locally dense grid for the Repository?” Select “No”.

3.1.7 Expected Results
From the menu bar, select File→Save→3D mesh→forTOUGH2. The mesh file is saved as “Test3D.mesh.”
Click No button on the pop-up window “Do you want to save index too?”

3.1.8 Installation Acceptance Criteria
Compare the “Test3D.mesh” with the provided file “Sample3D.mesh” to see if they are consistent. If there are no differences, the installation is considered successful.

3.1.9 Errors or Warning Conditions to Be Examined by Tester
The WindowsXP operating system gives errors and warning conditions of trouble with the system.

3.1.10 Instructions for Executing Installation Test Plan
No additional instructions are necessary to ensure the correct installation of the software.

3.2 VALIDATION TESTS
See Appendix B

3.3 CONTINUOUS USE SOFTWARE
N/A
4. REFERENCES/ATTACHMENTS


IT-PRO-0011, Rev.1, Software Management. DOC.20060929.0002

IT-PRO-0012, Rev.1, Qualification of Software. DOC.20060929.0006

IT-PRO-0013, Rev.1, Software Independent Verification and Validation. DOC.20060929.0019
APPENDIX A DESCRIPTION OF DATA FILES

All files below will be user-specified files (not fixed name files) in ASCII format except for those noted.

Input file

Domain Boundary File: The domain boundary file starts with a key word that contains a string "Domain". Following the key word (on the next row) are two numerical data entries, which represent the top and bottom elevations of the domain. Each row, thereafter, consists of two numerical data entries: the x and y coordinates, respectively. The set of vertices represents a polygon that describes its aerial extent. WINGRIDDER V3.0 shall accept multiple boundary files to facilitate assigning different grid parameters for different regions. The data and format of the other boundary files are similar with the domain boundary file. The key words in the boundary files (including the domain boundary file and the repository file described below) are unique and only one file can contain “Domain” in its key word in the group.

Single Region-Repository Files: The repository file starts with a key word that contains a string “Repo” but not “MultiRegion”. Following the key word (on the next row) are four numerical data entries, which represent the three parameters of the elevation equation and the thickness of the repository horizon. Each row, thereafter, consists of two numerical data entries: the x and y coordinates, respectively. The set of vertices represents a polygon that describes its aerial extent.

Multiple Region-Repository Files: The repository file starts with a key word that contains both strings of “Repo” and “MultiRegion”. Following the key word (on the next row) is the number of sub-regions. The data in each section are in the following order: number of vertices that describe the polygon and the thickness of the repository horizon for that sub-region of the repository; the x and y coordinates of each vertex (arranged counterclockwise, each vertex occupies one row); number of emplacement drifts and the drift radii; a string of “X   Y   Z   ID”; the x, y, z coordinates of a drift vertex and the drift ID (each vertex occupies one row). The last row of each section consists of three arbitrary digital numbers and a string that contains a sub-string “end” to indicate the end of the section.

Layer Files: Layer files include several files, a “layer list” file, a “layer order” file, a “rock type” file, rock zone files (optional if there are multiple rock zones in a hydraulic unit, up to three zones), and individual layer data files.

Layer list: The first row of data in the “layer list” file is the name of the site while the second row of the data is the filename of the “layer order” file. Starting from the third row, the “layer list” file lists a layer name (which shall be unique) and the associated data type (thickness or elevation) in each following row.

Layer order: The “layer order” file contains multiple sections. Each section of data represents one hydrogeologic layer and includes the layer name, a key word, the minimum x value (X_{min}), the minimum y value (Y_{min}), the x-spacing (DX), the y-spacing (DY), the number of grid points in x-direction (Nx), and the number of grid points in y-direction (Ny). The order of the layer
names reflects their relative stratigraphic positions. The layer names in the “layer order” file must be consistent with those in the “layer list” file. Three special key words, “top”, “refer”, and “bottom” are used for indicating three special horizons: the top boundary, the reference horizon, and the bottom boundary, respectively. These three layers (horizons) are not optional and must be defined by elevations (i.e., not thickness).

**Rock type:** The “rock type” file lists all layer names and their corresponding rock names. If a layer has multiple rock zones, this layer shall be associated with a “rock zone” filename instead of a rock name in the “rock type” file. A name is considered as a “rock zone” filename if it either starts with “al” or ends with “.ply”.

**Rock zone:** A “rock zone” file starts with the number of zones (Nzone) and the zone name of the default. Nzone-1 sections then followed, each defining one special zone. Each section starts with the number of vertices of the polygon and the zone name in the first row of that section, and is followed by the x, y coordinates of the vertices. Each vertex occupies one row. Note that the rock name will be the first three letters (after removing “al” from the filename if any) of the zone filename followed by the first two letters of the zone name.

**Individual layer data:** Each hydrogeologic layer has one individual layer file containing either elevation or thickness data on a regular horizontal grid spacing defined in the “layer order” file. The data in each individual layer file start from the point \((X_{\text{min}}, Y_{\text{min}})\) and are in following order:

\[
\begin{array}{l}
\text{For } l=1 \text{ to } N_y \\
\text{For } j=1 \text{ to } N_x
\end{array}
\]

All individual layer files will be in either binary format or ASCII format (have to be converted into binary before use in grid generation).

**Fault Files:** A fault file starts with a unique name and the width of the fault zone. It then contains three sections of numerical data that represent traces (x, y coordinates) of the fault at three different elevations.

**Drift Files:** Each drift file starts with a unique name and the drift radius, followed by x, y, z coordinates of the nodes that define the drift.

**Borehole File:** A borehole file contains data describing the x, y coordinates and unique name of each borehole to be located in the grid.

**Fracture File:** This file defines the fracture-related parameters for each rock type and will be used for dual-K or MINC grid generation. The first row can be any string either containing “default” or not. The second row contains SplitFactor and Gridtype (string). Gridtype can be any string except for reserved keywords “fixed”, “EQ2K”, or “activeF”. The keyword “activeF” indicates that the fracture-matrix interfaces in the grid will be consistent with the “active fracture model”. Other two reserved keywords are not currently required.
The third row is FractureType (integer). FractureType shall be one of “1” (a single set of parallel fractures), “2” (two perpendicular sets of parallel fractures), and “3” (three perpendicular sets of parallel fractures). The rest of data will be about each rock.

If the first row contains “default”, the data of each rock will have 1, 2, or 3 rows depending on the fracture type (1, 2, or 3). The first row is the same for all fracture type:
Rockname(string), FPorosity, Aperture, Spacing, AreaPerVol, Rfactor
The aperture and spacing in other directions are in the next one row (FractureType=2) or two rows (FractureType=3), respectively.

Otherwise, each following row contains the fracture data for one rock. They are:
Rockname(string), Fporosity, Aperture(1), Aperture(2), Aperture(3), Spacing(1), Spacing(2), Spacing(3), AreaPerVol, FractureType(integer).

All data above are real except for those indicated otherwise. The last row is the default fracture property set, which means that any rocks not in the list will use this default property set.

Output Files
Mesh File for TOUGH2 (*.mesh) : The mesh file for TOUGH2 is used as part of the input file for numerical simulations using TOUGH2. The mesh file contains three sections: the element section, the connection section, and the index section (optional). In the element section, each row of data represents a cell, and the cells are ordered column by column and from top to bottom within a column except the top and the bottom boundary cells which are arranged together for all columns. The mesh file extension is “.mesh.”

Mesh File for Checking (*.mck): This file is used to check the quality of the numerical grid generated by WINGRIDDER, with particular emphasis on demonstrating consistency with the input stratigraphic data. Each row of data contained in the file describes one cell, including its name, rock type, x, y coordinates, top and bottom elevations, the corresponding layer name, and the type of the cell. Overall, the data are ordered column-by-column and from top to bottom in each column. The file extension is “.mck.”

List of columns (*.lst): This file lists all qualified column names within the grid. Each row of data has the column’s name and the corresponding object (e.g., a fault, or a borehole) name. The file extension is “.lst.”

Segment File (*.grd): This file contains geometry information about segments (in map view) and is in a format used by Amesh. The file extension is “.grd.”

Graphic Files: These files are figures generated by WINGRIDDER and may be in variety of formats (e.g., EPS, BMP, etc.), depending on the configuration of the user’s printer (to file). Examples of graphic files are a layout of columns (2-D map view of nodes and cell boundaries), a map view of lateral connections, and a cross-sectional view of the 3-D grid.

Internal Files
Internal files are used by WINGRIDDER to store information about a project of grid generation and to transfer data between its components. The user should be aware of the information contained in each internal file, but should not modify it externally because it may corrupt the project.

**Project Files (*.prj):** This file contains information about columns, segments, name and path of the database files (if any), local refinement geometry (if any), and the current status of the project. The project file is saved when the user clicks Save on the Project menu and is loaded into memory when the user clicks Open on the Project menu. Using project files, the user can switch between different projects, modify a grid at a later date, or extract information from an existing grid without having to regenerate a grid every time. The file extension is “.prj.”

**Database Files (*.mdb):** Because a numerical grid often has a large number of cells and connections, the information on the 3-D grid is stored in a database file for each project. Currently, the database file is in Microsoft Access format. There are three tables in the database file: Cells, Faces, and Sides. The Cells table contains cell configuration information in each record, while the Faces table records information about the connections. The Sides table is used to track all neighboring cells and the corresponding connections of every cell (except the top and bottom neighbors, which are in the Cells table). The purpose of using database files is to enhance the performance of WINGRIDDER in handling larger grids. The file extension is “.mdb”.

**Node Files (*.in):** The node file is an input file for the modified Amesh used to generate a primary 2-D grid. The user clicks the Save button on the design platform to save the node file. Important information contained within this file includes the names and the x, y coordinates of nodes. The file extension is “.in.”

**Cell Files (*.cel):** The cell file is an output of the 2-D grid generator component of WINGRIDDER. The most important information in this file is the area of each column, which is loaded into memory by clicking Load→Grid under File in the menu bar. It has the same format as the cell file of Amesh. The file extension is “.cel.”

**Segment Files (*.grd):** This file is another output of the 2-D grid generator component of WINGRIDDER and has the same format as the segment file. It contains geometry information about all segments that outline the layout of columns. The segment file is loaded by clicking Load→Grid under File in the menu bar. The file extension is “.grd.”

**Selected Columns and Segments (*.scc):** This file contains a list of columns and segments selected by the user. These columns and segments may define a profile that a user wants to plot or write out. The file extension is “.scc.”
APPENDIX B THE TEST CASES

1. CASE 1: A SIMPLE 3-D GRID
This grid is designed to test the accuracy of geometrical calculations of the WINGRIDDER. The domain is 30×30×100 meters. There are three layers of rock: Rock1, Rock2, and Rock3. They have a thickness of 10, 40, and 50 meters, respectively. Various geometrical features of the generated grid can be validated against the theoretical values for this simple 3-D grid. The features include the volumes of cells, the interface areas of connections, the distance of a node to the interface, the layering interface represented by the grid, and the cosine of the angle between a connection and the vertical direction (cosZ). The 3-D grid should consist of 9 columns. Each column has 10 cells (exclude the boundary cells which are purely for the purpose of assigning the boundary conditions). As a result, the volume of each cell should have a size of 10×10×10 meters (=1000 m³); the interface area of each connection should be 10×10 (=100 m²); the distance of a node to the interface should be 5 meters; the layering interface should be at the elevation of 50 meters; and the absolute values of cosZ should be 1.0 (or –1.0) for vertical connections and 0 for horizontal connections, respectively.

The test case files are available from the installation media CD. The Case 1 is unzipped as “Case1.zip” in the CD. The user is required to unzip the file and copy to the installation directory before the user follows the steps follow.

1.1 Development of the grid
Step 1: Open WINGRIDDER V3.0 and click “Existing” button.
Double click the sub directory until “Case1” is reached and then Click “OK” button.
Select “Sample3D.bnd” and click “OK” button.

Step 2: Design and generate 2D (map view) grid
From menu bar, select Design 2D
Under “Select an Object,” choose DomainBound; Specify an Average Distance (node spacing): 10 (distance in meters) and click Add Nodes. A number of windows pop up. Enter the following information:
“Rectangular mesh?”; Click Yes button.
“Please enter Angle to PositiveX”: enter 0 (and hit Enter)
“Please enter the ratio of size: Y to X”: enter 1 (and hit Enter)
Click “Save” button and enter filename “Sample3D.in” in the File name box and then click “Save” button.

From the menu bar, select: Generate 2D
Select “Sample3D.in” and click “Open”

From the menu bar, select File→Load→Grid
Select file “Sample3D.grd” and click “Open”.
Click “OK” on the next window.

Step 3: Generate the 3-D grid
From the menu bar, select: Generate→3D→Full mesh
A window pops up and asks the user “Do you want to save the project automatically?”: Click “Yes” button.
Enter project filename as: “Sample3D_Veri.prj” and click “Save” button.
Pop-up windows appear for which the following information is specified:
“No layers! You Should load layer data first!”: click “OK” button.
Select “LayerList” in the Open File window and click “Open” button.
Select “LayerList.roc” in the Open File window and click “Open” button.
If the pop-up window with a question of “Do boreholes have their own layering information?” occurs, click “No” button. Otherwise go below.
“Use long LBNL name (8 characters)?”: Click “No” button.
“Please type in the MINIMUM thickness of a cell. A layer that has thickness smaller than this value will be ignored!”: enter 1 (and hit Enter).
“Please type in the MAXIMUM thickness of a cell. A layer that has thickness larger than this value will be subdivided!”: enter 10 (and hit Enter).
Click “Default” and then “OK” on the Edit Layer option window.
“Do you want to have a locally dense grid for the Repository?” Click “No” button.

1.2 Output
From the menu bar, select File → Save → 3Dmesh → forTOUGH2. Enter “Sample3D_Veri.mesh.” into File name box and then click “Save” button. Select No to the question “Do you want to save index too?”

1.3 Validation of the Grid
Option 1: compare the output file “Sample3D_Veri.mesh” with the provided mesh file “Sample3D.mesh” to check if they are consistent (e.g., using fc command in the DOS shell).

Option 2: Comparing the WINGRINDER output with the hand calculated values above checks the consistency between the generated 3-D grid and the hand-calculated grid. See Figure 1 for a sample output from WINGRIDER based on this simple grid. Exact matches are found for the volumes of cells (highlighted column under ELEME, 1000 m³), the interface areas of connections (second highlighted column under CONNE, 100 m²), the distance of a node to the interface (first highlighted column and first boxed column under CONNE, 5 m), the layering interface represented by the grid (two boxed rows under ELEME, height is midpoint between 45 m elevation and 55 m, so 50 m), and cosZ (second boxed column under CONNE, -1.0 for vertical connections and 0.0 for horizontal connections).
Figure 1: The grid file generated using WINGRIDDER V3.0 for case 1 (“…” represents the cells or the connections omitted in the figure).
2. CASE 2: CONSISTENCY BETWEEN WINGRIDDER-GENERATED GRID AND HYDROGEOLOGIC MODEL

This test case is designed to test the accuracy of the bi-linear interpolation method implemented in WINGRIDDER V3.0, which is used in calculating the elevation and the thickness of grid cells based on the given digital geological model (provided as data points at regular grid nodes). The relative error should be less than 1%.

The test case files are available from the installation media CD. The Case 2 is unzipped as “Case2.zip” in the CD. The user is required to unzip the file and copy to the installation directory before the user follows the steps follow.

2.1. Grid Development

**Step 1:** If WINGRIDDER V3.0 has not been opened (option 1):
Open WINGRIDDER V3.0 and click “Existing” button.
Double click the sub directory until “Case2” is reached and then Click “OK” button.
Select “CrossAt235087.bnd” and click “OK” button.
If WINGRIDDER V3.0 has already been opened (option 2):
From the menu bar, select: Project → Close
From the menu bar, select: Project → Get Directory
Double click the sub directory until “Case2” is reached and then Click “OK” button.
Select “CrossAt235087.bnd” and click “OK” button.

**Step 2:** Load the map-view design of the grid:
From the menu bar, select: Project → Open and select “CrossAt235087_2D.prj” and click “Open” button.
Click “OK” on the window of “This is a 2-D project!”

**Step 3:** From the menu bar, select: Generate → 3D → Cells/Vertical Cons Only
Click Yes if a window pops up with a question “3D Grid or 3D cells exist!! Are you sure you want rebuild?” Otherwise go below.
A window pops up and asks “Do you want to save the project automatically?” Click “Yes” button. Then enter “CrossAt235087_3D_Veri.prj” in the Saving Project file window and click “Save”.
Pop-up windows appear for which the following information is specified:
“Use long LBNL name (8)?” Click “Yes” button.
“No layers! You Should load layer data first!”: click “OK” button.
Select “LayerList” in the Open File window and click “Open” button.
Select “UZ99.roc” in the Open File window and click “Open” button.
If the pop-up window with a question of “Do boreholes have their own layering information?” occurs, click “No” button. Otherwise go below.
“Please type in the MINIMUM thickness of a cell. A layer that has thickness smaller than this value will be ignored!”: enter 0.01 (and hit Enter).
“Please type in the MAXIMUM thickness of a cell. A layer that has thickness larger than this value will be subdivided!”: enter 20 (and hit Enter).
Click “Default” and then “OK” button on the Edit Layer option window. “Do you want to have a locally dense grid for the Repository?” Click “No” button. WINGRIDDER will create 3-D cells and vertical connections.

**Step 4:** From the menu bar select: Generate → 3D → Lateral Cons Only

Respond to pop-up windows as follows:
“Please type in the MINIMUM thickness of a cell. A layer that has thickness smaller than this value will be ignored!”: enter 0.01 (and hit Enter).
The program runs and automatically saves the 3-D grid as: “CrossAt235087_3D_Veri.prj”

### 2.2. Outputs

From the menu bar, select Plot→Pickcolumn and then check the checkbox: Cells and Grid

Click Display

Click Pick Cells

Select the profile:
Move mouse to left side of the leftmost node and then click the left button while pressing Shift key down
Then move mouse to the right side of the rightmost node and then click the left button while pressing Shift key down

Click Picking Cells button

Click Yes on the pop-up window that shows a message “These two cells are not connected! Do you want WinGriddler to find the shortest connection to these two cells for you?”

Click OK on the pop-up window (note: it should show you that “You have selected 422 columns.” Otherwise, something wrong. You should repeat steps starting from Click Pick Cells.)

Check the Selected Cells check box and then click Display

From the menu bar, select File→Save→SelectedMesh→forTOUGH2. Enter “CrossAt235087_Veri.mesh” into the File name box and click “Save” button.

Click No on the pop-up window with a question “Do you want to save index too?”

Click No on the pop-up window with a question “Do you want save Selected Columns and Connections to file?”

### 2.3. Validation of the Grid

**Option 1:** compare the output file “CrossAt235087_Veri.mesh” with the provided mesh file “CrossAt235087-new.mesh” to check if they are consistent (e.g., using DOS shell command “fc”).

**Option 2:** Steps used in validation:

1. The x, y, z, and thickness data of all cells that belong to layer Tptpmn (TSw34) were extracted from the grid.
2. The top elevation and the thickness of the layer for each pair of (x, y) are calculated as the WINGRIDDER v3.0 interpolated values. The layer may be split into several grid cells at the same (x, y) location.
(3) Compare the elevation and thickness data to the data extracted from GFM3.1 using EARTHVISION V4.0 (STN: 30035 V4.0) for the same (x, y) locations. The results are shown in Figures 2 and 3 (elevations) and 4 and 5 (thicknesses). The maximum absolute difference is less than 0.15 m for elevation and 0.0016 m for thickness, which is way smaller than allowed values as defined in Section 2.0 (i.e., elevation: 1%×1230 = 12.3 m and thickness 1%×35 = 0.35 m).
Figure 2: Interpolated Elevation Comparison for Tptpmn (elevation)

Figure 3: Elevation Difference between WinGridder Interpolation and GFM 3.1 Interpolation (elevation)
Figure 4: Interpolated Elevation Comparison for Tptpmn (thickness)

![Interpolated Thickness Comparison for Tptpmn](image)

Figure 5: Elevation Difference between WINGRIDDER Interpolation and GFM 3.1 Interpolation (thickness)

![Thickness Difference between WinGridder Interpolation and GFM 3.1 Interpolation](image)
3. CASE 3: A HYBRID (PARTLY SINGLE CONTINUUM, DUAL-PERMEABILITY, AND MINC) GRID

This hybrid grid is for verification of the accuracy of the MINC grid generator as a component of the WINGRIDER. To be able to check the quality by hand-calculation, a simple and regular grid is used.

The test case files are available from the installation media CD. The Case 3 is unzipped as “Case3.zip” in the CD. The user is required to unzip the file and copy to the installation directory before the user follows the steps follow.

3.1 Development of a hybrid grid

Step 1: If WINGRIDER V3.0 has not been opened (option 1):
Open WINGRIDER V3.0 and click “Existing” button.
Double click the sub directory until “Case3” is reached and then Click “OK” button.
Select “Sample3D.bnd” and click “OK” button.
If WINGRIDER V3.0 has already been opened (option 2):
From the menu bar, select: Project → Close
From the menu bar, select: Project → Get Directory
Double click the sub directory until “Case3” is reached and then Click “OK” button.
Select “Sample3D.bnd” and click “OK” button.

Step 2: From menu bar, select Project → Open and then select “Sample3D.prj” and click “Open” button.

Notes: If a warning of “This is a 2D project!” occurs, modify the path in the “Sample3D.prj” (using a standard text editor to open the file, and do the following:
On the first line of the file, modify the path as to be the directory where the “Sample3D.bnd” from Case 1 resides.
Roll down to the end of the file, and modify the path as to be the directory where the file “Sample3D.mdb” resides.
Save the modified file. Then try to open the project file again.)

Step 3: From the menu bar, Select Generate → 3D → MINC Mesh
Select “FRAMTR3.fp” and click “Open” button;
Enter 5 on the “Enter number of matrix cells” box and click OK.
On the window of “Define the sub-mesh BOX”:
Select “constant” for “TOP” and then enter “70” into the “Elevation of TOP” box
Select “None” for “Bottom”
Select “LoadedObject” for “Sides” and then select “Domainbound” for “Existing polygons”
Click “Validate”. If any error occurs, correct it accordingly and then click “Validate” again until no error-warning window shows up.
Click “Finish”.
Click OK on pop-up window showing “the MINC grid has been created successfully”
Step 4: Output the hybrid mesh file

From the menu bar, Select File->Save->3Dmesh->MINC
Select “Sample3D_MINC5_v.mesh” on the “Opening DBFile file …” window and click “Open” button
Enter “Hybrid_veri.mesh” in the File name box on the Saving Mesh file …” window and click “Save” button.
Click “No” on the pop-up window with a question “Do you want to save Double Porosity type mesh (no global matrix connections).
Click “No” on the pop-up window with a question of “Do you want to save index too?”

3.2 Validation of the hybrid grid

Option 1: Compare the output files “Hybrid_veri.mesh” against the provided files “Hybrid.mesh” (e.g., use DOS shell command “fc”) to see if they are the same.

Option 2:
The original single-continuum grid is a 3×3×10 mesh (900 cells total, excluding top and bottom boundary cells) with 30×30×100 (m) domain. The “Rock1” has zero fracture volume so that the corresponding cells remain unchanged in the hybrid grid. The other two rocks have the same fracture properties: (1) the fracture volume is 1% of the bulk volume; (2) the fracture spacing is 1 meter; and (3) the interface area per bulk volume is 1.98 m²/m³. But “Rock3” is set to be dual-permeability-only in the fracture property file “FRAMTR3.fp”. In addition, in generating the MINC grid, we have also set that only the cells below the elevation of 70 m will be created as MINC grid (5 matrix cells). The base splitting factor is 2, which means that the volume of the matrix cells will be doubled moving away from the fracture-matrix interface. As a result of these settings, the hybrid grid will be created based on the original cell types as follows (see Section 3.2 in Design Document for calculation formula and note that the fracture type of this test case is 1-D):

<table>
<thead>
<tr>
<th>Original cell type</th>
<th>Criteria</th>
<th>New cells</th>
<th>New cell Volumes (m³)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rock type</td>
<td>Elevation (m)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1 Rock1 (no fracture)</td>
<td>Does not matter</td>
<td>One single-continuum cell</td>
<td>1000</td>
</tr>
<tr>
<td>2 Rock2 &gt; 70 m (outside of the user-specified MINC box)</td>
<td>One fracture cell (F-cell) and one Matrix cell (M-cell)</td>
<td>F-cell: 10 M-cell: 990</td>
<td></td>
</tr>
<tr>
<td>3 Rock2 &lt;70 m (inside the user-specified MINC box)</td>
<td>One F-cell and five Matrix cells (M-, N-, O-, P-, and Q-cell)</td>
<td>F-cell: 10 M-cell: 31.935 N-cell: 63.871 O-cell: 127.740 P-cell: 255.480 Q-cell: 510.970</td>
<td></td>
</tr>
<tr>
<td>4 Rock3 (dual-K)</td>
<td>Does not matter</td>
<td>One F-cell and one M-cell</td>
<td>F-cell:10 M-cell: 990</td>
</tr>
</tbody>
</table>
The nodal distances to the F-M interfaces are 0 and 0.1667 (m) for the fracture nodes and the matrix nodes, respectively, in dual-K case. The corresponding interface areas shall be 1980 m². In the case of MINC, the nodal distances to the internal interface and the corresponding interface areas shall be as follows:

<table>
<thead>
<tr>
<th>Interface</th>
<th>Area (m²)</th>
<th>Nodal distance (m)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>From left node</td>
<td>From right node</td>
</tr>
<tr>
<td>F-M</td>
<td>1.9800×10³</td>
<td>0</td>
</tr>
<tr>
<td>M-N</td>
<td>1.9820×10³</td>
<td>8.0565×10⁻³</td>
</tr>
<tr>
<td>N-O</td>
<td>1.9820×10³</td>
<td>1.6113×10⁻²</td>
</tr>
<tr>
<td>O-P</td>
<td>1.9820×10³</td>
<td>3.2226×10⁻²</td>
</tr>
<tr>
<td>P-Q</td>
<td>1.9820×10³</td>
<td>6.4452×10⁻²</td>
</tr>
</tbody>
</table>

The global connections to these matrix cells (M-, N-, O-, P-, and Q-cell) will have interface areas of 3.2258, 6.4516, 12.903, 25.806, and 51.613 (m²), respectively, which are calculated using the same splitting factors for the volumes. The nodal distances do not change for global connections.

4. CASE 4: CONSISTENCY BETWEEN WINGRIDDER-GENERATED GRID AND THE REPOSITORY GEOMETRY

This test case is mainly designed to test the accuracy of the grid-representation of the multi-region repository using WINGRIDDER V3.0. The grid itself is a 3-D site-scale grid including some major faults.

The test case files are available from the installation media CD. The Case 4 is unzipped as “Case4.zip” in the CD. The user is required to unzip the file and copy to the installation directory before the user follows the steps follow.

4.1. Grid development

Step 1: If WINGRIDDER V3.0 has not been opened (option 1):
Open WINGRIDDER V3.0 and click “Existing” button.
Double click the sub directory until “Case4” is reached and then Click “OK” button.
Select “Domain2001.bnd” and “repo2001.bnd” (press down Ctrl key and click left button of Mouse), and then click “OK” button.
If WINGRIDDER V3.0 has already been opened (option 2):
From the menu bar, select: Project → Close
From the menu bar, select: Project → Get Directory
Select “Domain2001.bnd” and “repo2001.bnd” (press down Ctrl key and click left button of Mouse), and then click “OK” button.

Step 2: Load the map-view design of grid:
From the menu bar, select: Project → Open
Select “Grid2001_2D.prj” and click “Open” button.
Click “OK” on the window of “This is a 2-D project!”

**Step 3:** From the menu bar, select: Edit→ Update Repo Columns→By Region (A progress bar will occur to show the job progress and the status also shown on lower-left corner).

**Step 4:** From the menu bar, select: Generate → 3D → Cells/Vertical Cons Only
If a window “3D Grid or 3D cells exist!! Are you sure you want rebuild?” pops up, click “Yes” button. Otherwise go below.
A window pops up and asks “Do you want to save the project automatically?” Click “Yes” button. Then enter “Grid2001_3D_Veri.prj” in the Saving Projectfile window and click “Save”.

Pop-up windows appear for which the following information is specified:
“Use long LBNL name (8)?” Click “Yes” button.
“No layers! You Should load layer data first!”: click “OK” button. Then
Select “LayerList” in the Open File window and click “Open” button.
Select “Layer2001.roc” in the Open File window and click “Open” button.
If a window with a question “Do boreholes have their own layering information?” pops up, Click “No” button. Otherwise, go below.
If a window asking “Do you want to set different water table in the area west of Sol canyon fault?” pops up, Click “No” button. Otherwise, go below.
“Please type in the MINIMUM thickness of a cell. A layer that has thickness smaller than this value will be ignored!”: enter 1.5 (and hit Enter).
“Please type in the MAXIMUM thickness of a cell. A layer that has thickness larger than this value will be subdivided!”: enter 60 (and hit Enter).
Click “Default” and then “OK” on the Edit Layer option window.
“Do you want to have a locally dense grid for the Repository?” Click “No”. WINGRIDDER will create 3-D cells and vertical connections.

**Step 5:** From the menu bar select: Generate → 3D → Lateral Cons Only
Response to pop-up windows as following:
“Please type in the MINIMUM thickness of a cell. A layer that has thickness smaller than this value will be ignored!”: enter 1.5 (and hit Enter).
The program runs and saves the 3-D grid as: “Grid2001_3D_Veri.prj” automatically.

**4.2. Outputs**
From the menu bar, select File→Save→3Dmesh→ForTOUGH2. Then enter “Grid2001_Veri.mesh” and click “Save” button. Click No button to the question of “Do you want to save index too?”

**4.3. Validation of the Grid**
**Option 1:** Comparing “Grid2001_Veri.mesh” with the provided mesh file “Grid2001.mesh” to check if they are consistent (e.g. use DOS shell command “fc”).

**Option 2:**
Steps used for validation:
Extract x, y, z data of repository cells, 014De36, 014De40, 014De45, 014De50, and 014De55 from the grid. These cells belong to emplacement drifts 29, 30, 31, 32, and 33, respectively.
Compare these data with the corresponding elevation data of the repository drifts in the repository input data file (i.e., repo2001.bnd). The elevations of drifts 29, 30, 31, 32, and 33 are 1069.206, 1070.577, 1071.548, 1072.719, and 1073.891 (m), respectively.
In addition, one can check the rock property for the fault cell in the outputted mesh file. For example, the fault cell ‘0005A 1’ has rock of ‘ptnfl’, which is one of the four fault-rock names.